Bug 99366 - ResourceLoader::sendResourceLoadCallbacks() is backwards
Summary: ResourceLoader::sendResourceLoadCallbacks() is backwards
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nate Chapin
URL:
Keywords:
Depends on:
Blocks: 49246
  Show dependency treegraph
 
Reported: 2012-10-15 14:17 PDT by Nate Chapin
Modified: 2012-10-16 10:30 PDT (History)
3 users (show)

See Also:


Attachments
patch (1.37 KB, patch)
2012-10-15 14:23 PDT, Nate Chapin
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Chapin 2012-10-15 14:17:51 PDT
...it does an implicit enum to bool conversion which returns the opposite value of what is intended.

It isn't used currently, but will be used in a later patch for supporting main resources in the memory cache.
Comment 1 Nate Chapin 2012-10-15 14:23:25 PDT
Created attachment 168781 [details]
patch
Comment 2 Daniel Bates 2012-10-15 22:06:31 PDT
Comment on attachment 168781 [details]
patch

This patch looks straightforward to me.
Comment 3 WebKit Review Bot 2012-10-15 22:14:47 PDT
Comment on attachment 168781 [details]
patch

Clearing flags on attachment: 168781

Committed r131411: <http://trac.webkit.org/changeset/131411>
Comment 4 WebKit Review Bot 2012-10-15 22:14:50 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Alexey Proskuryakov 2012-10-16 10:29:18 PDT
Comment on attachment 168781 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=168781&action=review

> Source/WebCore/ChangeLog:3
> +        ResourceLoader::sendResourceLoadCallbacks() is backwards

It's also badly misnamed. A function with this name should send callbacks when called, not just access a member variable.
Comment 6 Nate Chapin 2012-10-16 10:30:44 PDT
(In reply to comment #5)
> (From update of attachment 168781 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=168781&action=review
> 
> > Source/WebCore/ChangeLog:3
> > +        ResourceLoader::sendResourceLoadCallbacks() is backwards
> 
> It's also badly misnamed. A function with this name should send callbacks when called, not just access a member variable.

...I never noticed that. Now it irritates me.

Will fix :)