Bug 98717 - JSC: Rename RegisterFile to JSStack
Summary: JSC: Rename RegisterFile to JSStack
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-08 21:22 PDT by Mark Lam
Modified: 2012-10-09 09:40 PDT (History)
10 users (show)

See Also:


Attachments
Fix: renamed RegisterFile to JSStack, and removed the prototype of the previously deleted Interpreter::privateExecute(). (256.53 KB, patch)
2012-10-08 21:38 PDT, Mark Lam
fpizlo: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2012-10-08 21:22:04 PDT
This is just a refactoring job to rename RegisterFile to JSStack in preparation for topCallFrame changes.  The are no semantic changes in this change set.
Comment 1 Mark Lam 2012-10-08 21:38:53 PDT
Created attachment 167685 [details]
Fix: renamed RegisterFile to JSStack, and removed the prototype of the previously deleted Interpreter::privateExecute().
Comment 2 WebKit Review Bot 2012-10-08 21:42:17 PDT
Attachment 167685 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/CMakeLists.txt', u'S..." exit_code: 1
Source/JavaScriptCore/interpreter/JSStack.h:40:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Source/JavaScriptCore/runtime/JSLock.cpp:146:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
Source/JavaScriptCore/runtime/JSLock.cpp:149:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
Total errors found: 3 in 69 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Mark Lam 2012-10-08 21:45:45 PDT
(In reply to comment #2)
> Source/JavaScriptCore/interpreter/JSStack.h:40:  Code inside a namespace should not be indented.  [whitespace/indent] [4]

This indentation was there before.  To minimize the diff, I'm leaving them as is.

> Source/JavaScriptCore/runtime/JSLock.cpp:146:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
> Source/JavaScriptCore/runtime/JSLock.cpp:149:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
> Total errors found: 3 in 69 files

These spaces were there before my change, and they make the comment more readable.  I'm leaving them as is.
Comment 4 Filip Pizlo 2012-10-08 22:44:43 PDT
Ready for review?

(I'm tempted to rubber stamp. I concur with the renaming.)
Comment 5 Mark Lam 2012-10-08 23:08:16 PDT
Comment on attachment 167685 [details]
Fix: renamed RegisterFile to JSStack, and removed the prototype of the previously deleted Interpreter::privateExecute().

Was waiting for some of the ews bots to confirm that I didn't bork their builds.  We're ready for the review now.
Comment 6 Filip Pizlo 2012-10-08 23:46:55 PDT
R=me.
Comment 7 Mark Lam 2012-10-09 00:13:31 PDT
Landed in <http://trac.webkit.org/changeset/130726>.
Comment 8 Geoffrey Garen 2012-10-09 09:39:07 PDT
Makes me think that "CallFrame" should be renamed to "StackFrame" or "JSStackFrame".
Comment 9 Mark Lam 2012-10-09 09:40:51 PDT
(In reply to comment #8)
> Makes me think that "CallFrame" should be renamed to "StackFrame" or "JSStackFrame".

I will revisit that later.