Bug 98623 - Robohornet's reflow test spends 2% of total time in ScrollbarThemeMac::registerScrollbar calling NSClassFromString("ScrollBarImp")
Summary: Robohornet's reflow test spends 2% of total time in ScrollbarThemeMac::regist...
Status: RESOLVED DUPLICATE of bug 98622
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-07 12:54 PDT by Eric Seidel (no email)
Modified: 2012-10-07 15:06 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2012-10-07 12:54:00 PDT
Robohornet's reflow test spends 2% of total time in ScrollbarThemeMac::registerScrollbar calling NSClassFromString("ScrollBarImp")

http://www.robohornet.org/tests/offsetreflow.html

An easy fix would be to cache the class pointer, since it's unlikely to change. :)

Unclear how much (if at all) this affects real web content.
Comment 1 Eric Seidel (no email) 2012-10-07 15:06:56 PDT
Actually, I don't think it's the ClassFromString lookup.  This may just be a dupe of bug 98622.

*** This bug has been marked as a duplicate of bug 98622 ***