Bug 98587 - REGRESSION (r130570): fast/writing-mode/vertical-subst-font-vert-no-dflt.html fails on non-Chromium platforms
Summary: REGRESSION (r130570): fast/writing-mode/vertical-subst-font-vert-no-dflt.html...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 50619 51584
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 23:35 PDT by Zan Dobersek
Modified: 2013-04-09 17:07 PDT (History)
4 users (show)

See Also:


Attachments
GTK actual output (8.91 KB, image/png)
2012-10-05 23:37 PDT, Zan Dobersek
no flags Details
GTK expected output (8.84 KB, image/png)
2012-10-05 23:37 PDT, Zan Dobersek
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2012-10-05 23:35:45 PDT
fast/writing-mode/vertical-subst-font-vert-no-dflt.html is failing on non-Chromium platforms since being introduced in r130570.
http://trac.webkit.org/changeset/130570
http://test-results.appspot.com/dashboards/flakiness_dashboard.html#group=%40ToT%20-%20webkit.org&tests=fast%2Fwriting-mode%2Fvertical-subst-font-vert-no-dflt.html
Comment 1 Zan Dobersek 2012-10-05 23:37:21 PDT
Created attachment 167442 [details]
GTK actual output
Comment 2 Zan Dobersek 2012-10-05 23:37:50 PDT
Created attachment 167444 [details]
GTK expected output
Comment 3 Zan Dobersek 2012-10-05 23:38:57 PDT
(In reply to comment #1)
> Created an attachment (id=167442) [details]
> GTK actual output

(In reply to comment #2)
> Created an attachment (id=167444) [details]
> GTK expected output

To analyze the GTK results, it seems as the actual output is correct while the expected output is not rendered correctly.
Comment 4 Xianzhu Wang 2012-10-06 10:56:34 PDT
(In reply to comment #3)
> (In reply to comment #1)
> > Created an attachment (id=167442) [details] [details]
> > GTK actual output
> 
> (In reply to comment #2)
> > Created an attachment (id=167444) [details] [details]
> > GTK expected output
> 
> To analyze the GTK results, it seems as the actual output is correct while the expected output is not rendered correctly.

No. According to Unicode standard, the puctucations in CJK vertical text, the punctuations should be rotated, that is, the glyphs should be substituted with the corresponding vertical forms of them according to the GSUB table in the font.
Comment 5 Xianzhu Wang 2012-10-06 11:00:09 PDT
(In reply to comment #3)
> (In reply to comment #1)
> > Created an attachment (id=167442) [details] [details]
> > GTK actual output
> 
> (In reply to comment #2)
> > Created an attachment (id=167444) [details] [details]
> > GTK expected output
> 
> To analyze the GTK results, it seems as the actual output is correct while the expected output is not rendered correctly.

(Sorry for early enter of #4. Please ignore it)

No. According to Unicode standard, for the puctucations in CJK vertical text, the glyphs should be substituted with the corresponding vertical forms of them according to the GSUB table in the font. The new layout test is testing this behavior. It's a bug that the glyphs are not properly substituted.
Comment 6 Xianzhu Wang 2012-10-06 11:06:01 PDT
(In reply to comment #5)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > Created an attachment (id=167442) [details] [details] [details]
> > > GTK actual output
> > 
> > (In reply to comment #2)
> > > Created an attachment (id=167444) [details] [details] [details]
> > > GTK expected output
> > 
> > To analyze the GTK results, it seems as the actual output is correct while the expected output is not rendered correctly.
> 
> (Sorry for early enter of #4. Please ignore it)
> 
(In reply to comment #5)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > Created an attachment (id=167442) [details] [details] [details]
> > > GTK actual output
> > 
> > (In reply to comment #2)
> > > Created an attachment (id=167444) [details] [details] [details]
> > > GTK expected output
> > 
> > To analyze the GTK results, it seems as the actual output is correct while the expected output is not rendered correctly.
> 
> (Sorry for early enter of #4. Please ignore it)
> 
> No. According to Unicode standard, for the puctucations in CJK vertical text, the glyphs should be substituted with the corresponding vertical forms of them according to the GSUB table in the font. The new layout test is testing this behavior. It's a bug that the glyphs are not properly substituted.

Sorry I misunderstood the comment about expected and actual results. #3 is correct. In the expected result the vertical forms are unnecessarily rotated, perhaps because the characters are not treated as CJK characters (which should not be rotated in vertical text).
Comment 7 Csaba Osztrogonác 2012-10-08 08:39:18 PDT
Skipped on Qt by https://trac.webkit.org/changeset/130628.
Please unskip it with the proper fix.
Comment 8 Xianzhu Wang 2012-10-08 11:47:39 PDT
Checked the GTK output again, and found that this is a more fundamental issue: the GTK port just doesn't do anything for vertical CJK text. It just rotates all CJK glyphs same as other glyphs, so the original forms of the punctuations are rotated "as expected", and the ideographs and vertical forms are also rotated unexpectedly. (bug 50619)
Comment 9 Xianzhu Wang 2012-10-08 11:48:35 PDT
(In reply to comment #7)
> Skipped on Qt by https://trac.webkit.org/changeset/130628.
> Please unskip it with the proper fix.

Could you attach the actual and expected images on Qt? Thanks.
Comment 12 Xianzhu Wang 2012-10-08 13:53:51 PDT
(In reply to comment #11)
> Ooops, it was wrong URL.
> 
> Here is the correct one: http://build.webkit.sed.hu/results/x86-64%20Linux%20Qt%20Release/r130627%20%2843536%29/fast/writing-mode/vertical-subst-font-vert-no-dflt-diffs.html

Thanks for the result. So this is the bug: https://bugs.webkit.org/show_bug.cgi?id=51584.
Comment 13 Stephen Chenney 2013-04-09 17:07:18 PDT
Marked LayoutTest bugs, bugs with Chromium IDs, and some others as WontFix. Test failure bugs still are trackable via TestExpectations or disabled unit tests.