Bug 98250 - Web Inspector: second level rows in bottom-up CPU profile view are empty
: Web Inspector: second level rows in bottom-up CPU profile view are empty
Status: RESOLVED INVALID
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated)
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 03:06 PDT by Yury Semikhatsky
Modified: 2012-10-03 04:41 PDT (History)
11 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Semikhatsky 2012-10-03 03:06:36 PDT
Steps to reproduce:
1. Take CPU profile.
2. Switch to bottom-up view and try to expand any top-level entry

Result:
'Function' field in the child entries is empty.

Here is the original user report: https://groups.google.com/d/msg/google-chrome-developer-tools/9m_d76P98u4/PcwjHgZO5-EJ
the user observed that on  Chromium 22.0.1229.79 m on Windows 7 64-bit.
I managed to reproduce that on Chrome Linux 22.0.1229.91
Comment 1 Yury Semikhatsky 2012-10-03 03:07:26 PDT
There is an exception in the console if you open inspector on inspector window:

Uncaught TypeError: Cannot call method 'rawLocationToUILocation' of undefined DevTools.js:67662
Comment 2 Vsevolod Vlasov 2012-10-03 04:41:59 PDT
I am closing this as invalid because this issue is already fixed in ToT.
https://code.google.com/p/chromium/issues/detail?id=153748 is tracking merging the fix into Chrome.