RESOLVED FIXED 97326
[WK2][WKTR] EventSender needs to implement scheduleAsynchronousClick
https://bugs.webkit.org/show_bug.cgi?id=97326
Summary [WK2][WKTR] EventSender needs to implement scheduleAsynchronousClick
Chris Dumez
Reported 2012-09-21 04:03:27 PDT
WebKitTestRunner's EventSender does not implement scheduleAsynchronousClick(), causing the following test case to fail: fast/events/popup-blocking-click-in-iframe.html
Attachments
Patch (10.34 KB, patch)
2012-09-21 04:07 PDT, Chris Dumez
kenneth: review+
cdumez: commit-queue-
Patch (14.01 KB, patch)
2012-09-21 05:29 PDT, Chris Dumez
no flags
Chris Dumez
Comment 1 2012-09-21 04:07:44 PDT
Kenneth Rohde Christiansen
Comment 2 2012-09-21 05:02:34 PDT
Comment on attachment 165111 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=165111&action=review > Tools/WebKitTestRunner/InjectedBundle/EventSendingController.cpp:240 > + WKRetainPtr<WKStringRef> EventSenderMessageName(AdoptWK, WKStringCreateWithUTF8CString("EventSender")); > + WKRetainPtr<WKMutableDictionaryRef> EventSenderMessageBody(AdoptWK, WKMutableDictionaryCreate()); Nit: geolocation etc use lowercase messages, maybe we want to be consistent > Tools/WebKitTestRunner/InjectedBundle/EventSendingController.cpp:250 > + WKRetainPtr<WKStringRef> subMessageKey(AdoptWK, WKStringCreateWithUTF8CString("SubMessage")); Is submessage really a good way to describe this? > Tools/WebKitTestRunner/InjectedBundle/EventSendingController.cpp:253 > + WKBundlePostMessage(InjectedBundle::shared().bundle(), EventSenderMessageName.get(), EventSenderMessageBody.get()); I would add a newline after post > Tools/WebKitTestRunner/TestController.cpp:694 > +#if PLATFORM(MAC) || PLATFORM(QT) || PLATFORM(GTK) || PLATFORM(EFL) So which webkit2 platforms does this not work on?
Chris Dumez
Comment 3 2012-09-21 05:09:13 PDT
Comment on attachment 165111 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=165111&action=review >> Tools/WebKitTestRunner/InjectedBundle/EventSendingController.cpp:240 >> + WKRetainPtr<WKMutableDictionaryRef> EventSenderMessageBody(AdoptWK, WKMutableDictionaryCreate()); > > Nit: geolocation etc use lowercase messages, maybe we want to be consistent Those messages already exists and their format is already predefined. I cannot change them. Those messages are used already in EventSendingController::mouseDown() and EventSendingController::mouseUp(). >> Tools/WebKitTestRunner/InjectedBundle/EventSendingController.cpp:250 >> + WKRetainPtr<WKStringRef> subMessageKey(AdoptWK, WKStringCreateWithUTF8CString("SubMessage")); > > Is submessage really a good way to describe this? Ditto. >> Tools/WebKitTestRunner/InjectedBundle/EventSendingController.cpp:253 >> + WKBundlePostMessage(InjectedBundle::shared().bundle(), EventSenderMessageName.get(), EventSenderMessageBody.get()); > > I would add a newline after post Ok. >> Tools/WebKitTestRunner/TestController.cpp:694 >> +#if PLATFORM(MAC) || PLATFORM(QT) || PLATFORM(GTK) || PLATFORM(EFL) > > So which webkit2 platforms does this not work on? I used this to be consistent with TestController::didReceiveSynchronousMessageFromInjectedBundle().
Chris Dumez
Comment 4 2012-09-21 05:23:37 PDT
Comment on attachment 165111 [details] Patch I think I can do some refactoring to avoid patch duplication.
Chris Dumez
Comment 5 2012-09-21 05:29:05 PDT
Created attachment 165120 [details] Patch - Add createMouseMessageBody() convenience function to avoid code duplication for creating mouse messages - Add newline as suggested by Kenneth
Kenneth Rohde Christiansen
Comment 6 2012-09-21 06:06:59 PDT
Comment on attachment 165120 [details] Patch nice
WebKit Review Bot
Comment 7 2012-09-21 06:15:57 PDT
Comment on attachment 165120 [details] Patch Clearing flags on attachment: 165120 Committed r129220: <http://trac.webkit.org/changeset/129220>
WebKit Review Bot
Comment 8 2012-09-21 06:16:02 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.