Bug 97280 - REGRESSION (r126763): Incorrect line breaking when both kerning and word spacing are enabled
Summary: REGRESSION (r126763): Incorrect line breaking when both kerning and word spac...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Nobody
URL: data:text/html,%3Cdiv%20style=%22bord...
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2012-09-20 18:48 PDT by mitz
Modified: 2012-09-21 09:21 PDT (History)
1 user (show)

See Also:


Attachments
Make TextLayout::width() apply word spacing except at the first character of a run (4.31 KB, patch)
2012-09-21 00:21 PDT, mitz
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2012-09-20 18:48:38 PDT
To reproduce:
run-webkit-tests --complex fast/text/basic/004.html

Line breaking isn’t accounting for word spacing correctly.

This was caused by <http://trac.webkit.org/r126763>, the fix for bug 83045.
Comment 1 mitz 2012-09-20 21:01:39 PDT
Please ignore the original description. The failure happens when the test is modified to enable kerning.
Comment 2 mitz 2012-09-20 21:08:46 PDT
The URL contains a reduction.
<div style="border: solid; width: 50px; word-spacing: 50px; -webkit-font-kerning: normal;">a b</div>
Comment 3 mitz 2012-09-20 23:41:31 PDT
TextLayout uses fontWithNoWordSpacing…
Comment 4 mitz 2012-09-21 00:21:21 PDT
Created attachment 165064 [details]
Make TextLayout::width() apply word spacing except at the first character of a run
Comment 5 mitz 2012-09-21 09:21:48 PDT
Fixed in <http://trac.webkit.org/r129233>.