Bug 9711 - More Safari AJAX history bugs
Summary: More Safari AJAX history bugs
Status: RESOLVED DUPLICATE of bug 6309
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P4 Normal
Assignee: Nobody
URL: http://bloomd.home.mchsi.com/histapi/...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-03 08:00 PDT by Eric Seidel (no email)
Modified: 2006-07-09 14:35 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2006-07-03 08:00:49 PDT
Another site I ran accross on the net.  Although it doesn't break down into a single test case, the essay he's written about how he got safari support working (through serious hacks) is useful, and probably could be broken up into bugs.
Comment 1 David Kilzer (:ddkilzer) 2006-07-03 08:57:17 PDT
I am 99% sure this was fixed with Anders' patch for Bug 6309 (and is thus a duplicate).  The workaround is very interesting, though!

Have you tried a nightly WebKit build, Eric?  :)

Comment 2 Anders Carlsson 2006-07-09 14:35:22 PDT
That's right. With 6309 fixed, Safari can use the "regular" way of doing AJAX history

*** This bug has been marked as a duplicate of 6309 ***