It is possible to do this in Chrome. Difference is WK2 isn't treating the click as a user gesture.
Created attachment 164460 [details]
Comment on attachment 164460 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=164460&action=review
> + UserGestureIndicator gestureIndicator(DefinitelyProcessingUserGesture);
A “why” comment would be welcome here. Also, I think the local variable can be named "indicator".
Not caused by this patch: I also think that RAII objects with side effects need clearer names. It’s not at all clear that an indicator is an object that affects global state.
Committed 129140: http://trac.webkit.org/changeset/129140