Bug 9676 - Too much whitespace between comment field & submit button @ bugzilla attachment page
Summary: Too much whitespace between comment field & submit button @ bugzilla attachme...
Status: RESOLVED DUPLICATE of bug 8735
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://bugzilla.opendarwin.org/attach...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-01 11:28 PDT by Geoffrey Garen
Modified: 2006-07-02 03:40 PDT (History)
3 users (show)

See Also:


Attachments
Screenshot -- Firefox (8.54 KB, image/png)
2006-07-01 11:29 PDT, Geoffrey Garen
no flags Details
Screenshot -- WebKit (10.65 KB, image/png)
2006-07-01 11:29 PDT, Geoffrey Garen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Garen 2006-07-01 11:28:40 PDT
1. Pick any bugzilla bug.
2. Click 'Create a new attachment'
3. Notice that the submit button at the bottom of the page is far below the comment field

Screenshots forthcoming.
Comment 1 Geoffrey Garen 2006-07-01 11:29:03 PDT
Created attachment 9124 [details]
Screenshot -- Firefox
Comment 2 Geoffrey Garen 2006-07-01 11:29:30 PDT
Created attachment 9125 [details]
Screenshot -- WebKit
Comment 3 David Kilzer (:ddkilzer) 2006-07-01 18:11:26 PDT
If you click the "Patch" checkbox on this page, some legal text about submitting patches is showing.  My guess is that whatever mechanism is being used to hide the text doesn't collapse the space.

Hmm...looks like the culprit is the "visibility: collapse;" style.

Copying Joost on this bug since he's the Bugzilla look-and-feel guru.

Comment 4 Mark Rowe (bdash) 2006-07-02 02:03:56 PDT
This is caused by WebKit treating "visibility: collapse" the same as "visibility: hidden".  See http://www.w3.org/TR/CSS21/tables.html#dynamic-effects for information about how it should be treated, and http://www.quirksmode.org/css/visibility.html for an example that compares its behaviour with various settings for the visibility and display property.
Comment 5 David Kilzer (:ddkilzer) 2006-07-02 03:40:27 PDT

*** This bug has been marked as a duplicate of 8735 ***