Bug 96685 - Rename forEachCell to forEachLiveCell
Summary: Rename forEachCell to forEachLiveCell
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Hahnenberg
Depends on:
Reported: 2012-09-13 12:50 PDT by Mark Hahnenberg
Modified: 2012-09-13 13:08 PDT (History)
1 user (show)

See Also:

Patch (6.01 KB, patch)
2012-09-13 13:04 PDT, Mark Hahnenberg
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hahnenberg 2012-09-13 12:50:07 PDT
forEachCell actually only iterates over live cells. We should rename it to reflect what it actually does. This is also helpful because I want to add a new forEachCell that actually does iterate each and every cell in a MarkedBlock regardless of whether or not it is live.
Comment 1 Mark Hahnenberg 2012-09-13 13:04:07 PDT
Created attachment 163945 [details]
Comment 2 Mark Hahnenberg 2012-09-13 13:08:27 PDT
Committed r128498: <http://trac.webkit.org/changeset/128498>