Bug 96662 - Web Inspector: [Tests] Extract a common method for sending xhrs from tests.
Summary: Web Inspector: [Tests] Extract a common method for sending xhrs from tests.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Vsevolod Vlasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-13 09:41 PDT by Vsevolod Vlasov
Modified: 2012-09-14 01:35 PDT (History)
10 users (show)

See Also:


Attachments
Patch (44.12 KB, patch)
2012-09-13 09:43 PDT, Vsevolod Vlasov
apavlov: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vsevolod Vlasov 2012-09-13 09:41:54 PDT
Patch to follow
Comment 1 Vsevolod Vlasov 2012-09-13 09:43:53 PDT
Created attachment 163891 [details]
Patch
Comment 2 Alexander Pavlov (apavlov) 2012-09-14 01:16:35 PDT
Comment on attachment 163891 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=163891&action=review

> LayoutTests/ChangeLog:3
> +        Web Inspector: [Tests] Extract a common method for sending xhrs from tests.

WebKit convention is to capitalize full acronyms, even in identifiers (like "runXHRTest")

> LayoutTests/http/tests/inspector/network-test.js:98
> +function makeXHR(jsonArgs)

Please come up with a consistent naming convention for these methods (doXHR vs. makeXHR vs. InspectorTest.makeXHR*)
Comment 3 Vsevolod Vlasov 2012-09-14 01:35:56 PDT
Committed r128569: <http://trac.webkit.org/changeset/128569>