Bug 96266 - [Qt] Drastically shorten length of commandline needed for JS bindings generator
Summary: [Qt] Drastically shorten length of commandline needed for JS bindings generator
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Hausmann
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-10 06:04 PDT by Simon Hausmann
Modified: 2012-09-12 07:26 PDT (History)
4 users (show)

See Also:


Attachments
Patch (4.95 KB, patch)
2012-09-10 06:07 PDT, Simon Hausmann
no flags Details | Formatted Diff | Diff
Patch (5.34 KB, patch)
2012-09-12 01:09 PDT, Simon Hausmann
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Hausmann 2012-09-10 06:04:40 PDT
[Qt] Drastically shorten length of commandline needed for JS bindings generator
Comment 1 Simon Hausmann 2012-09-10 06:07:26 PDT
Created attachment 163108 [details]
Patch
Comment 2 WebKit Review Bot 2012-09-10 06:29:46 PDT
Comment on attachment 163108 [details]
Patch

Clearing flags on attachment: 163108

Committed r128054: <http://trac.webkit.org/changeset/128054>
Comment 3 WebKit Review Bot 2012-09-10 06:29:49 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Tor Arne Vestbø 2012-09-11 07:53:42 PDT
I don't think this worked :/ After a clean build no files are generated:

http://build.webkit.org/builders/Qt%20Windows%2032-bit%20Release/builds/54510/steps/compile-webkit/logs/stdio
Comment 5 Csaba Osztrogonác 2012-09-11 08:04:28 PDT
Rollout landed in https://trac.webkit.org/changeset/128187
Comment 6 Simon Hausmann 2012-09-11 10:44:31 PDT
(In reply to comment #4)
> I don't think this worked :/ After a clean build no files are generated:
> 
> http://build.webkit.org/builders/Qt%20Windows%2032-bit%20Release/builds/54510/steps/compile-webkit/logs/stdio

It's really weird since this worked great for me locally. But I think my machine must've smoked something, because now that I look at the command line ...

    set "SOURCE_ROOT=c:\foo" && perl -I...

it probably interprets the whole thing as just one big set line with strange garbage at the end. IOW, I'll probably have to add parentheses.

I'll fix it tomorrow. Thanks for rolling it out :)
Comment 7 Simon Hausmann 2012-09-12 00:43:30 PDT
Ok, I can confirm the issue and adding parentheses fixed it. I'll re-land the fix with parentheses.
Comment 8 Simon Hausmann 2012-09-12 01:09:46 PDT
Created attachment 163538 [details]
Patch

New patch for review with a beautiful qmake function that Tor Arne is going to love ;)
Comment 9 Simon Hausmann 2012-09-12 01:10:31 PDT
(In reply to comment #8)
> Created an attachment (id=163538) [details]
> Patch
> 
> New patch for review with a beautiful qmake function that Tor Arne is going to love ;)

The trick is that while on Windows we need to surrounding the set with parentheses, it will break on *nix because the parentheses open up a sub-shell and the export becomes invisible to the surrounding shell.
Comment 10 WebKit Review Bot 2012-09-12 07:26:08 PDT
Comment on attachment 163538 [details]
Patch

Clearing flags on attachment: 163538

Committed r128307: <http://trac.webkit.org/changeset/128307>
Comment 11 WebKit Review Bot 2012-09-12 07:26:11 PDT
All reviewed patches have been landed.  Closing bug.