Bug 96107 - [Gtk] Enable Resource Timing
Summary: [Gtk] Enable Resource Timing
Status: RESOLVED DUPLICATE of bug 30685
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: José Dapena Paz
URL:
Keywords:
Depends on: 61138
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 07:36 PDT by José Dapena Paz
Modified: 2017-07-24 13:33 PDT (History)
4 users (show)

See Also:


Attachments
Patch (10.12 KB, patch)
2012-09-07 07:50 PDT, José Dapena Paz
pnormand: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description José Dapena Paz 2012-09-07 07:36:05 PDT
Add settings for enabling performance timeline and resource timing support in WebKit GTK+. It will be disabled by default, waiting for a sufficiently mature implementation.
Comment 1 José Dapena Paz 2012-09-07 07:50:46 PDT
Created attachment 162770 [details]
Patch

Patch adding settings for enabling resource timing and performance timeline
Comment 2 Martin Robinson 2012-09-07 08:47:50 PDT
Comment on attachment 162770 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=162770&action=review

> configure.ac:981
> +# check whether to enable Performance Timeline support
> +AC_MSG_CHECKING([whether to enable Performance Timeline support])
> +AC_ARG_ENABLE(performance_timeline,
> +              AC_HELP_STRING([--enable-performance-timeline],
> +                             [enable support for Performance Timeline (experimental) [default=no]]),
> +              [],[enable_performance_timeline=$enable_unstable_features])
> +AC_MSG_RESULT([$enable_performance_timeline])

I don't think we add configuration options for features that aren't complete yet. Zan has the details.
Comment 3 Zan Dobersek 2012-09-07 09:33:46 PDT
Comment on attachment 162770 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=162770&action=review

>> configure.ac:981
>> +AC_MSG_RESULT([$enable_performance_timeline])
> 
> I don't think we add configuration options for features that aren't complete yet. Zan has the details.

Correct. Both these features don't introduce any dependencies so the configuration flags aren't required.

Besides all the changes in configure.ac, this also removes the need for checking the Automake conditionals in Source/WebCore/GNUmakefile.am.
Comment 4 Philippe Normand 2013-04-12 12:21:28 PDT
Comment on attachment 162770 [details]
Patch

This one got bitrot :( At least the autotools part. Would need to be rebased so EWS can process it.
Comment 5 Brian Burg 2017-07-24 13:33:10 PDT

*** This bug has been marked as a duplicate of bug 30685 ***