RESOLVED FIXED 95742
Need to run git commands within the checkout directory
https://bugs.webkit.org/show_bug.cgi?id=95742
Summary Need to run git commands within the checkout directory
Satish Sampath
Reported 2012-09-04 06:30:08 PDT
git commands run from Tools/Scripts/webkitpy/common/checkout/scm/git.py are sometimes run with cwd set to the checkout_root and other times with whatever directory was the default cwd. Instead all these should run with the checkout root set as the cwd (except where we explicitly need a different path)
Attachments
Patch (17.15 KB, patch)
2012-09-04 06:36 PDT, Satish Sampath
no flags
Patch (17.15 KB, patch)
2012-09-04 07:37 PDT, Satish Sampath
no flags
Satish Sampath
Comment 1 2012-09-04 06:36:00 PDT
Peter Beverloo
Comment 2 2012-09-04 06:44:34 PDT
Comment on attachment 162031 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=162031&action=review One minor nit. Thanks, seems like a good clean-up overall :-). Did you intend to request commit as well? > Tools/Scripts/webkitpy/common/checkout/scm/git.py:101 > + def _run_exe(self, command_args, **kwargs): nit: I'm not thrilled about the "_run_exe" name, maybe something like "_run_git_command" would be better? If this issue applies to svn as well, maybe this could be generalized in the SCM class and name it "_run_scm_command"..
Satish Sampath
Comment 3 2012-09-04 07:37:11 PDT
Comment on attachment 162031 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=162031&action=review >> Tools/Scripts/webkitpy/common/checkout/scm/git.py:101 >> + def _run_exe(self, command_args, **kwargs): > > nit: I'm not thrilled about the "_run_exe" name, maybe something like "_run_git_command" would be better? If this issue applies to svn as well, maybe this could be generalized in the SCM class and name it "_run_scm_command".. I'll rename it to _run_git() similar to how there is a _run_svn() in svn.py. Since I don't have an svn checkout don't know if that has similar issues, would be better for someone with an svn checkout to send a patch if they find an issue with it.
Satish Sampath
Comment 4 2012-09-04 07:37:26 PDT
Adam Barth
Comment 5 2012-09-04 11:41:11 PDT
Eric should probably review this patch.
Eric Seidel (no email)
Comment 6 2012-09-04 12:44:03 PDT
Comment on attachment 162041 [details] Patch Seems like a win. Thanks!
WebKit Review Bot
Comment 7 2012-09-04 14:22:38 PDT
Comment on attachment 162041 [details] Patch Clearing flags on attachment: 162041 Committed r127507: <http://trac.webkit.org/changeset/127507>
WebKit Review Bot
Comment 8 2012-09-04 14:22:42 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.