Bug 9543 - background not clipped by border-radius on ancestor when overflow is not visible
: background not clipped by border-radius on ancestor when overflow is not visible
Status: RESOLVED DUPLICATE of bug 50072
Product: WebKit
Classification: Unclassified
Component: CSS
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
http://web.nickshanks.com/browsers/ie...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-22 02:22 PDT by Nicholas Shanks
Modified: 2011-09-26 16:09 PDT (History)
5 users (show)

See Also:


Attachments
test case (1006 bytes, text/html)
2009-05-19 08:12 PDT, Nicholas Shanks
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Shanks 2006-06-22 02:22:51 PDT
When overflow is not set to visible, the background image of a child element should be clipped by the border-radius of a parent element. Currently it just overflows as if there was no clipping.
Comment 1 Simon Fraser (smfr) 2009-05-15 23:28:04 PDT
This is fixed now. Try a webkit nightly build.
Comment 2 Nicholas Shanks 2009-05-19 08:11:47 PDT
It's not fixed as of r43841 running on Leopard. In the test case I am just about to attach, the five rounded rects should look the same due to the "overflow: hidden" on the bordered div.
Comment 3 Nicholas Shanks 2009-05-19 08:12:31 PDT
Created attachment 30469 [details]
test case
Comment 4 Simon Fraser (smfr) 2011-09-26 16:09:58 PDT

*** This bug has been marked as a duplicate of bug 50072 ***