Bug 95395 - [Chromium] The CC button is not painted
Summary: [Chromium] The CC button is not painted
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Victor Carbune
URL:
Keywords:
Depends on:
Blocks: 84672
  Show dependency treegraph
 
Reported: 2012-08-29 15:58 PDT by Victor Carbune
Modified: 2012-08-30 11:52 PDT (History)
6 users (show)

See Also:


Attachments
Fix (6.56 KB, patch)
2012-08-29 16:12 PDT, Victor Carbune
no flags Details | Formatted Diff | Diff
Fixed minor issue (6.85 KB, patch)
2012-08-30 03:20 PDT, Victor Carbune
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Carbune 2012-08-29 15:58:52 PDT
The actual resource for the closed caption button needs to be used and painted.
Comment 1 Victor Carbune 2012-08-29 16:12:46 PDT
Created attachment 161348 [details]
Fix
Comment 2 Victor Carbune 2012-08-30 03:20:58 PDT
Created attachment 161434 [details]
Fixed minor issue
Comment 3 Victor Carbune 2012-08-30 03:22:19 PDT
Comment on attachment 161348 [details]
Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=161348&action=review

> Source/WebCore/rendering/RenderMediaControlsChromium.cpp:374
>      case MediaShowClosedCaptionsButton:

Sorry, this was faulty as the switch case statement above were falling through. Fixed.
Comment 4 Gyuyoung Kim 2012-08-30 03:27:39 PDT
Comment on attachment 161434 [details]
Fixed minor issue

Attachment 161434 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/13689633
Comment 5 Victor Carbune 2012-08-30 06:16:42 PDT
(In reply to comment #4)
> (From update of attachment 161434 [details])
> Attachment 161434 [details] did not pass efl-ews (efl):
> Output: http://queues.webkit.org/results/13689633
Hmm, I don't think this break is caused by my patch.
Comment 6 Eric Carlson 2012-08-30 10:29:40 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > (From update of attachment 161434 [details] [details])
> > Attachment 161434 [details] [details] did not pass efl-ews (efl):
> > Output: http://queues.webkit.org/results/13689633
> Hmm, I don't think this break is caused by my patch.

I agree. Clearing cq-.
Comment 7 WebKit Review Bot 2012-08-30 11:52:38 PDT
Comment on attachment 161434 [details]
Fixed minor issue

Clearing flags on attachment: 161434

Committed r127168: <http://trac.webkit.org/changeset/127168>
Comment 8 WebKit Review Bot 2012-08-30 11:52:41 PDT
All reviewed patches have been landed.  Closing bug.