Rename paintIntoRegion and hitTestRegion so that they can take a flow thread portion that isn't necessarily tied to the flow thread portion of the entire region. In order to work with region sets like the new multicolumn layout, these functions have to be able to paint a portion of a portion.
Created attachment 161002 [details]
Comment on attachment 161002 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=161002&action=review
> + Rename regionRect()/setRegionRect()/m_regionRect on RenderRegion to be flowThreadPortionRect instead.
flowThreadPortion is a bit of a mouthful, but I can't think of anything better.
Landed in r126895.