Bug 94724 - [BlackBerry] Extend LayerFilterRenderer in preparation for CSS Shaders
Summary: [BlackBerry] Extend LayerFilterRenderer in preparation for CSS Shaders
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit BlackBerry (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 94728
  Show dependency treegraph
 
Reported: 2012-08-22 10:32 PDT by Joshua Netterfield
Modified: 2012-08-24 08:12 PDT (History)
5 users (show)

See Also:


Attachments
Patch (21.62 KB, patch)
2012-08-23 15:22 PDT, Joshua Netterfield
no flags Details | Formatted Diff | Diff
Patch (20.72 KB, patch)
2012-08-24 07:22 PDT, Joshua Netterfield
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Netterfield 2012-08-22 10:32:53 PDT
There are some features missing in LayerFilterRenderer that are needed to implement CSS Shaders for BB10.
Comment 1 Joshua Netterfield 2012-08-23 15:22:22 PDT
Created attachment 160262 [details]
Patch
Comment 2 Arvid Nilsson 2012-08-24 07:01:37 PDT
Comment on attachment 160262 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=160262&action=review

LGTM, but please remove copy/paste in favor of LayerRenderer::orthoMatrix()

> Source/WebCore/platform/graphics/blackberry/LayerFilterRenderer.cpp:240
> +static void orthogonalProjectionMatrix(TransformationMatrix& matrix, float left, float right, float bottom, float top)

This code is already available in LayerRenderer::orthoMatrix(), no need for copy/paste

> Source/WebCore/platform/graphics/blackberry/LayerFilterRenderer.h:48
> +    virtual void onCompletion() { }

The "on" prefix is not typically used in WebKit, instead they use the will/did/should or other prefixes. In this case, maybe a better name that doesn't even need a prefix can be made. The name is nothing to R- for, but it is unusual for the WebKit codebase.

Since the calling function is called cleanUp() maybe this could be called cleanUp() to, but I'm not sure. To me, it looks like the clean up performed is mostly related to restoring state, so maybe restoreState() or something along those lines would make sense.
Comment 3 Joshua Netterfield 2012-08-24 07:22:01 PDT
Created attachment 160419 [details]
Patch
Comment 4 Arvid Nilsson 2012-08-24 07:40:07 PDT
Comment on attachment 160419 [details]
Patch

Looks great!
Comment 5 WebKit Review Bot 2012-08-24 08:12:32 PDT
Comment on attachment 160419 [details]
Patch

Clearing flags on attachment: 160419

Committed r126587: <http://trac.webkit.org/changeset/126587>
Comment 6 WebKit Review Bot 2012-08-24 08:12:35 PDT
All reviewed patches have been landed.  Closing bug.