Bug 94486 - REGRESSION (r121482, Lion-only): Closing a popover containing a WKView can crash
Summary: REGRESSION (r121482, Lion-only): Closing a popover containing a WKView can crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.7
: P1 Major
Assignee: John Sullivan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2012-08-20 09:30 PDT by John Sullivan
Modified: 2012-08-20 09:54 PDT (History)
0 users

See Also:


Attachments
Patch to avoid a line of recently-added code in the problematic case, only on OS X 10.7 (2.54 KB, patch)
2012-08-20 09:38 PDT, John Sullivan
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Sullivan 2012-08-20 09:30:44 PDT
<http://trac.webkit.org/changeset/121482> fixed a class of undo-related bugs where undo entries were left on the stack after their target was dealloc’ed. This triggered a Lion-only crash closing an NSPopover that contains a WKView, due to an object lifetime bug in AppKit. This AppKit bug was fixed in OS X 10.8. This bug represents working around that AppKit bug in OS X 10.7.

This is in Radar as <rdar://problem/12128557>.
Comment 1 John Sullivan 2012-08-20 09:38:22 PDT
Created attachment 159453 [details]
Patch to avoid a line of recently-added code in the problematic case, only on OS X 10.7
Comment 2 John Sullivan 2012-08-20 09:54:54 PDT
Fixed in http://trac.webkit.org/changeset/126041