Bug 94288 - RenderBox::computeLogicalClientHeight is incorrectly named
Summary: RenderBox::computeLogicalClientHeight is incorrectly named
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ojan Vafai
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-16 19:08 PDT by Ojan Vafai
Modified: 2012-09-12 15:29 PDT (History)
6 users (show)

See Also:


Attachments
Patch (7.84 KB, patch)
2012-09-12 14:43 PDT, Ojan Vafai
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ojan Vafai 2012-08-16 19:08:46 PDT
clientHeight should include padding but exclude scrollbars (and RenderBox::clientHeight does!). RenderBox::computeLogicalClientHeight returns the box-sizing adjusted content height (excluding both padding and scrollbars). It's especially confusing because computeContentLogicalHeightUsing returns the content height not adjusted for box-sizing and including the scrollbar and computeLogicalHeightUsing returns the border-box size (including scrollbar obviously).

Can't think of a better name at the moment, but computeLogicalClientHeight is definitely wrong.
Comment 1 Ojan Vafai 2012-09-12 14:43:43 PDT
Created attachment 163700 [details]
Patch
Comment 2 WebKit Review Bot 2012-09-12 15:29:19 PDT
Comment on attachment 163700 [details]
Patch

Clearing flags on attachment: 163700

Committed r128371: <http://trac.webkit.org/changeset/128371>
Comment 3 WebKit Review Bot 2012-09-12 15:29:22 PDT
All reviewed patches have been landed.  Closing bug.