Bug 94075 - CSS3 animationstart, animationend and animationiteration events are not emitted
: CSS3 animationstart, animationend and animationiteration events are not emitted
Status: RESOLVED INVALID
Product: WebKit
Classification: Unclassified
Component: CSS
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 00:37 PDT by Alexander Shalamov
Modified: 2012-08-22 10:05 PDT (History)
1 user (show)

See Also:


Attachments
Test (985 bytes, text/html)
2012-08-15 00:38 PDT, Alexander Shalamov
no flags Details
Test2 (913 bytes, text/html)
2012-08-22 07:46 PDT, Alexander Shalamov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Shalamov 2012-08-15 00:37:25 PDT
According to http://www.w3.org/TR/css3-animations/#animation-events , animationstart, animationend and animationiteration events should be fired.
Comment 1 Alexander Shalamov 2012-08-15 00:38:07 PDT
Created attachment 158518 [details]
Test

Simple test that reproduces the problem
Comment 2 Jussi Kukkonen (jku) 2012-08-22 03:27:19 PDT
From the CSS WG June 6th meeeting (http://lists.w3.org/Archives/Public/www-style/2012Jun/0105.html):
> RESOLVED: Transitions, Transforms, and Animations may be released unprefixed.


So this should be fine. I assume there's pressure to keep the prefixed versions as well?
Comment 3 Jussi Kukkonen (jku) 2012-08-22 05:19:24 PDT
The events are there, just prefixed, marking this a duplicate of the larger "should unprefix" -bug

*** This bug has been marked as a duplicate of bug 93136 ***
Comment 4 Alexander Shalamov 2012-08-22 07:44:35 PDT
Reopening, this bug is about different issue.
Comment 5 Alexander Shalamov 2012-08-22 07:46:02 PDT
Created attachment 159931 [details]
Test2
Comment 6 Alexander Shalamov 2012-08-22 07:49:34 PDT
This bug about animation events. In webkit, there is no way to add event listener to animated element and listen to animation events.

Jussi, you could open test file in mozilla and webkit browser and check what's the output.
Comment 7 Jussi Kukkonen (jku) 2012-08-22 08:31:50 PDT
(In reply to comment #6)
> This bug about animation events. In webkit, there is no way to add event listener to animated element and listen to animation events.
> 
> Jussi, you could open test file in mozilla and webkit browser and check what's the output.

It passes in webkit if you just change the event name to "webkitAnimationStart" (note capitalization in addition to prefix).
Comment 8 Alexander Shalamov 2012-08-22 10:05:33 PDT
My bad, didn't try that combination.
Thanks for clarification.