Bug 93834 - [V8] Move hintForGCIfNecessary() from V8Proxy.h to V8GCController.h
Summary: [V8] Move hintForGCIfNecessary() from V8Proxy.h to V8GCController.h
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kentaro Hara
URL:
Keywords:
Depends on:
Blocks: 85330
  Show dependency treegraph
 
Reported: 2012-08-13 05:56 PDT by Kentaro Hara
Modified: 2012-08-13 19:25 PDT (History)
3 users (show)

See Also:


Attachments
Patch (3.92 KB, patch)
2012-08-13 05:57 PDT, Kentaro Hara
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kentaro Hara 2012-08-13 05:56:29 PDT
We can move hintForGCIfNecessary() from V8Proxy.h to V8GCController.h.
Comment 1 Kentaro Hara 2012-08-13 05:57:46 PDT
Created attachment 157975 [details]
Patch
Comment 2 Adam Barth 2012-08-13 10:39:15 PDT
Comment on attachment 157975 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=157975&action=review

> Source/WebCore/bindings/v8/V8GCController.cpp:525
> +    if (data->shouldCollectGarbageSoon()) {

Prefer early return.

> Source/WebCore/bindings/v8/V8GCController.cpp:526
> +        const int longIdlePauseInMs = 1000;

longIdlePauseInMs -> longIdlePauseInMS

> Source/WebCore/bindings/v8/V8GCController.h:79
> +        static void hintForGCIfNecessary();

Can we think of a better name for this function?  Perhaps collectGarbageIfNecessary?
Comment 3 Kentaro Hara 2012-08-13 18:32:20 PDT
(In reply to comment #2)
> > Source/WebCore/bindings/v8/V8GCController.cpp:525
> > +    if (data->shouldCollectGarbageSoon()) {
> 
> Prefer early return.
> 
> > Source/WebCore/bindings/v8/V8GCController.cpp:526
> > +        const int longIdlePauseInMs = 1000;
> 
> longIdlePauseInMs -> longIdlePauseInMS
> 
> > Source/WebCore/bindings/v8/V8GCController.h:79
> > +        static void hintForGCIfNecessary();
> 
> Can we think of a better name for this function?  Perhaps collectGarbageIfNecessary?

Done.
Comment 4 Kentaro Hara 2012-08-13 18:32:29 PDT
Committed r125491: <http://trac.webkit.org/changeset/125491>