Bug 9371 - Flash video disabled at www.shunra.com
Summary: Flash video disabled at www.shunra.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.shunra.com
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-09 02:02 PDT by Alexey Proskuryakov
Modified: 2007-10-23 11:26 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2006-06-09 02:02:17 PDT
Steps to reproduce:

1. Open www.shunra.com
2. Try using the DHTML menu at the top (SOLUTIONS/PROJECTS/CUSTOMERS/...). Move the mouse pointer down.

Results: Parts of the menu disapppear or flicker as you move the mouse, may re-appear after a while.

This seems to be yet another plugin z-order issue, but the behavior looks different enough from what I saw before. Firefox displays the menus just fine.
Comment 1 Lewis Francis 2006-11-14 11:51:58 PST
This seems to be fixed in the later nightlies.
Comment 2 Alexey Proskuryakov 2006-11-14 12:12:53 PST
There is no flickering with current WebKit, but that's not because the bug was fixed, I'm afraid :(. Flash just cannot draw its animation for whatever reason.
Comment 3 Lewis Francis 2006-11-14 12:34:06 PST
Hmm...I see that now.  I ran across your report while checking on a similar flickering prob; in our case, our alpha-fade animation continues to play fine while the drop-down menu overlays the swf, and the flickering is absent on at least later webkit builds. 

Maybe it would make sense to add the additional behavior to the description, or make a new report and call this one done?
Comment 4 Alexey Proskuryakov 2006-11-16 10:48:05 PST
The site intentionally stops animation in Safari now (by hiding the Flash content with display:none). This doesn't really help shipping Safari, as drawing glitches still occur, but spoofing User-Agent proves that TOT functions correctly.
Comment 5 Mark Hubbart 2007-10-23 09:39:09 PDT
I see no problems in r26929... is this resolved in safari's nightly builds, or in the actual site?
Comment 6 Alexey Proskuryakov 2007-10-23 11:26:48 PDT
The site now works fine in both Tiger Safari/WebKit and TOT - apparently, they have found some workaround for Safari!