Bug 93655 - Vertical writing mode can overflow fixed size grandparent container
: Vertical writing mode can overflow fixed size grandparent container
Status: RESOLVED FIXED
: WebKit
Layout and Rendering
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
: 96031
: 96557
  Show dependency treegraph
 
Reported: 2012-08-09 14:20 PST by
Modified: 2013-01-04 12:47 PST (History)


Attachments
original testcase (2.44 KB, text/html)
2012-08-09 14:21 PST, Ojan Vafai
no flags Details
reduction (858 bytes, text/html)
2012-08-09 14:21 PST, Ojan Vafai
no flags Details
Patch (21.28 KB, patch)
2012-09-07 15:55 PST, Ojan Vafai
no flags Review Patch | Details | Formatted Diff | Diff
Patch (219.01 KB, patch)
2012-09-13 13:46 PST, Ojan Vafai
no flags Review Patch | Details | Formatted Diff | Diff
Patch (221.86 KB, patch)
2012-09-13 16:11 PST, Ojan Vafai
no flags Review Patch | Details | Formatted Diff | Diff
Patch (221.67 KB, patch)
2012-09-14 15:15 PST, Ojan Vafai
no flags Review Patch | Details | Formatted Diff | Diff
Update to ToT (223.49 KB, patch)
2012-10-09 10:43 PST, Ojan Vafai
no flags Review Patch | Details | Formatted Diff | Diff
Patch (226.49 KB, patch)
2013-01-04 11:03 PST, Ojan Vafai
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-08-09 14:20:00 PST
Moving over test-cases from bug 87679 to focus on the writing-mode bug since that bug had two separate bugs (a flexbox bug and a writing-mode bug).
------- Comment #1 From 2012-08-09 14:21:18 PST -------
Created an attachment (id=157545) [details]
original testcase
------- Comment #2 From 2012-08-09 14:21:32 PST -------
Created an attachment (id=157546) [details]
reduction
------- Comment #3 From 2012-08-09 14:56:48 PST -------
As best I can tell, this is the correct behavior per the old spec: http://dev.w3.org/csswg/css3-writing-modes/#orthogonal-auto.

But the definition of fill-available in the height direction has changed in the new spec to walk up the tree until it finds a containing block with a definite height: http://dev.w3.org/csswg/css3-sizing/#extrinsic-sizing.
------- Comment #4 From 2012-08-09 15:01:18 PST -------
(In reply to comment #3)
> As best I can tell, this is the correct behavior per the old spec: http://dev.w3.org/csswg/css3-writing-modes/#orthogonal-auto.
> 
> But the definition of fill-available in the height direction has changed in the new spec to walk up the tree until it finds a containing block with a definite height: http://dev.w3.org/csswg/css3-sizing/#extrinsic-sizing.

There's no fill-available in your test case though?
------- Comment #5 From 2012-08-09 15:12:54 PST -------
(In reply to comment #4)
> There's no fill-available in your test case though?

The writing-mode spec link defines the auto-sized height for an orthogonal writing-mode in terms of the fill-available height.
------- Comment #6 From 2012-09-07 15:55:15 PST -------
Created an attachment (id=162893) [details]
Patch
------- Comment #7 From 2012-09-13 13:46:59 PST -------
Created an attachment (id=163956) [details]
Patch
------- Comment #8 From 2012-09-13 16:11:00 PST -------
Created an attachment (id=163993) [details]
Patch
------- Comment #9 From 2012-09-14 00:49:19 PST -------
(From update of attachment 163993 [details])
Attachment 163993 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/13839844

New failing tests:
fast/writing-mode/percentage-height-orthogonal-writing-modes-quirks.html
------- Comment #10 From 2012-09-14 15:15:49 PST -------
Created an attachment (id=164234) [details]
Patch
------- Comment #11 From 2012-10-01 13:40:45 PST -------
(From update of attachment 164234 [details])
The table border models test case looks like a regression. "Header One" is not fitting on one line.
------- Comment #12 From 2012-10-01 13:52:41 PST -------
(In reply to comment #11)
> (From update of attachment 164234 [details] [details])
> The table border models test case looks like a regression. "Header One" is not fitting on one line.

I'm pretty sure this is correct. If you load it at tip of tree and force the height of the vertical-rl div to 586px, then you get the same wrapping behavior. This patch causes the difference because we now subtract the body's margin when computing the availableHeight.
------- Comment #13 From 2012-10-09 10:43:37 PST -------
Created an attachment (id=167780) [details]
Update to ToT
------- Comment #14 From 2012-10-19 13:16:17 PST -------
Anyone mind taking a stab a reviewing this?
------- Comment #15 From 2013-01-04 11:03:19 PST -------
Created an attachment (id=181335) [details]
Patch
------- Comment #16 From 2013-01-04 11:28:28 PST -------
(From update of attachment 181335 [details])
r=me
------- Comment #17 From 2013-01-04 12:46:57 PST -------
(From update of attachment 181335 [details])
Clearing flags on attachment: 181335

Committed r138838: <http://trac.webkit.org/changeset/138838>
------- Comment #18 From 2013-01-04 12:47:03 PST -------
All reviewed patches have been landed.  Closing bug.