RESOLVED FIXED 93609
Rename functions in the ARM port of DFG-JIT for better code readability.
https://bugs.webkit.org/show_bug.cgi?id=93609
Summary Rename functions in the ARM port of DFG-JIT for better code readability.
Gabor Ballabas
Reported 2012-08-09 05:21:40 PDT
Rename functions in the ARM port of DFG-JIT for better code readability. Also for better following of WebKit coding style.
Attachments
Patch (58.74 KB, patch)
2012-08-09 05:34 PDT, Gabor Ballabas
no flags
Add a couple of function renaming to the previous patch. (64.78 KB, patch)
2012-08-10 05:52 PDT, Gabor Ballabas
no flags
Final patch (65.78 KB, patch)
2012-08-10 08:33 PDT, Gabor Ballabas
zherczeg: review-
zherczeg: commit-queue-
Patch (65.70 KB, patch)
2012-08-14 03:29 PDT, Gabor Ballabas
no flags
Gabor Ballabas
Comment 1 2012-08-09 05:34:04 PDT
Gabor Ballabas
Comment 2 2012-08-10 05:52:35 PDT
Created attachment 157718 [details] Add a couple of function renaming to the previous patch.
Gabor Ballabas
Comment 3 2012-08-10 08:33:06 PDT
Created attachment 157738 [details] Final patch
Filip Pizlo
Comment 4 2012-08-13 15:50:11 PDT
Comment on attachment 157738 [details] Final patch It's worth noting that for the assembler backends, we typically use underscore naming. I'm fine with this patch, but I think maybe Zoltan would be a better judge of whether you want to change naming in this way.
Filip Pizlo
Comment 5 2012-08-13 15:50:43 PDT
Zoltan, r=me if you're fine with this.
Zoltan Herczeg
Comment 6 2012-08-14 02:28:38 PDT
Comment on attachment 157738 [details] Final patch View in context: https://bugs.webkit.org/attachment.cgi?id=157738&action=review > Source/JavaScriptCore/assembler/ARMAssembler.h:470 > - void vsqrt_f64_r(int dd, int dm, Condition cc = AL) > + void vsqrtFloat64(int dd, int dm, Condition cc = AL) Do not rename this, only remove the _r. There are other similar instances, probavbly a followup patch. > Source/JavaScriptCore/assembler/ARMAssembler.h:475 > - void vabs_f64_r(int dd, int dm, Condition cc = AL) > + void vabsFloat64(int dd, int dm, Condition cc = AL) Ditto. > Source/JavaScriptCore/assembler/ARMAssembler.h:480 > - void vneg_f64_r(int dd, int dm, Condition cc = AL) > + void vnegFloat64(int dd, int dm, Condition cc = AL) Ditto.
Gabor Ballabas
Comment 7 2012-08-14 03:29:46 PDT
Gabor Ballabas
Comment 8 2012-08-14 03:30:41 PDT
(In reply to comment #6) > (From update of attachment 157738 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=157738&action=review > > > Source/JavaScriptCore/assembler/ARMAssembler.h:470 > > - void vsqrt_f64_r(int dd, int dm, Condition cc = AL) > > + void vsqrtFloat64(int dd, int dm, Condition cc = AL) > > Do not rename this, only remove the _r. There are other similar instances, probavbly a followup patch. > > > Source/JavaScriptCore/assembler/ARMAssembler.h:475 > > - void vabs_f64_r(int dd, int dm, Condition cc = AL) > > + void vabsFloat64(int dd, int dm, Condition cc = AL) > > Ditto. > > > Source/JavaScriptCore/assembler/ARMAssembler.h:480 > > - void vneg_f64_r(int dd, int dm, Condition cc = AL) > > + void vnegFloat64(int dd, int dm, Condition cc = AL) > > Ditto. Done.
Zoltan Herczeg
Comment 9 2012-08-14 03:39:37 PDT
Comment on attachment 158278 [details] Patch r=me
WebKit Review Bot
Comment 10 2012-08-14 04:28:41 PDT
Comment on attachment 158278 [details] Patch Clearing flags on attachment: 158278 Committed r125541: <http://trac.webkit.org/changeset/125541>
WebKit Review Bot
Comment 11 2012-08-14 04:28:45 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.