Bug 93545 - Animation keyframes do not function when placed in a style element in a shadowRoot
Summary: Animation keyframes do not function when placed in a style element in a shado...
Status: RESOLVED DUPLICATE of bug 72462
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.7
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on: 72462
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 16:08 PDT by Steve Orvell
Modified: 2012-11-02 03:51 PDT (History)
5 users (show)

See Also:


Attachments
Reduction (1.44 KB, text/html)
2012-08-08 16:08 PDT, Steve Orvell
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Orvell 2012-08-08 16:08:36 PDT
Created attachment 157320 [details]
Reduction

If a style element inside a shadowRoot defines an animation via @-webkit-keyframes, the animation does not run when used within the shadowRoot.

However, if a style element inside a shadowRoot refers to an animation in a document style element, the animation does run when used within the shadowRoot.
Comment 1 Takashi Sakamoto 2012-08-09 19:00:11 PDT
As styles in a shadow DOM subtree are treated as "scoped" and all scoped @keyframes are ignored (c.f. bug 72462), @-webkit-keyframes declared in a shadow DOM subtree doesn't work.

c.f. 
StyleResolver.cpp
            // FIXME (BUG 72462): We don't add @keyframe rules of scoped style sheets for the moment.                                                                      
            if (scope)
                continue;
            resolver->addKeyframeStyle(static_cast<StyleRuleKeyframes*>(rule));

and 
<style scoped>: Implement scoped @keyframes
https://bugs.webkit.org/show_bug.cgi?id=72462

Best regards,
Takashi Sakamoto

(In reply to comment #0)
> Created an attachment (id=157320) [details]
> Reduction
> 
> If a style element inside a shadowRoot defines an animation via @-webkit-keyframes, the animation does not run when used within the shadowRoot.
> 
> However, if a style element inside a shadowRoot refers to an animation in a document style element, the animation does run when used within the shadowRoot.
Comment 2 Dominic Cooney 2012-08-12 21:23:52 PDT
What should the semantics here be?
Comment 3 Takashi Sakamoto 2012-11-02 03:51:45 PDT

*** This bug has been marked as a duplicate of bug 72462 ***