Bug 93301 - test-webkitpy hangs in a new checkout on snow leopard
Summary: test-webkitpy hangs in a new checkout on snow leopard
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dirk Pranke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-06 15:34 PDT by Dirk Pranke
Modified: 2012-08-07 15:39 PDT (History)
5 users (show)

See Also:


Attachments
Patch (10.54 KB, patch)
2012-08-06 15:37 PDT, Dirk Pranke
rniwa: review+
dpranke: commit-queue?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Pranke 2012-08-06 15:34:52 PDT
test-webkitpy hangs in a new checkout on snow leopard
Comment 1 Dirk Pranke 2012-08-06 15:37:15 PDT
Created attachment 156774 [details]
Patch
Comment 2 Dirk Pranke 2012-08-06 15:45:31 PDT
Note that running test-webkitpy a second time seems to pass.

Also note that this is a conservative patch; I didn't want to try and figure out what was hanging or why, as that seemed like it might be a fragile solution, and also more time-consuming than was really warranted.
Comment 3 Ryosuke Niwa 2012-08-06 15:52:00 PDT
Comment on attachment 156774 [details]
Patch

Confirmed that this fixes the problem at least on my Snow Leopard machine.
Comment 4 Ojan Vafai 2012-08-06 15:54:06 PDT
Comment on attachment 156774 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=156774&action=review

> Tools/Scripts/webkitpy/test/main.py:133
> +        if installed_something:

Should we restrict this to python older than 2.6.5?
Comment 5 Dirk Pranke 2012-08-06 15:57:06 PDT
(In reply to comment #4)
> (From update of attachment 156774 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=156774&action=review
> 
> > Tools/Scripts/webkitpy/test/main.py:133
> > +        if installed_something:
> 
> Should we restrict this to python older than 2.6.5?

We could; I don't feel strongly about it, and this will only have an impact if we are actually autoinstalling things, which should only happen rarely.
Comment 6 Dirk Pranke 2012-08-06 15:57:30 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > (From update of attachment 156774 [details] [details])
> > View in context: https://bugs.webkit.org/attachment.cgi?id=156774&action=review
> > 
> > > Tools/Scripts/webkitpy/test/main.py:133
> > > +        if installed_something:
> > 
> > Should we restrict this to python older than 2.6.5?
> 
> We could; I don't feel strongly about it, and this will only have an impact if we are actually autoinstalling things, which should only happen rarely.

Would you like me to restrict it?
Comment 7 Ojan Vafai 2012-08-06 16:31:40 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > (From update of attachment 156774 [details] [details] [details])
> > > View in context: https://bugs.webkit.org/attachment.cgi?id=156774&action=review
> > > 
> > > > Tools/Scripts/webkitpy/test/main.py:133
> > > > +        if installed_something:
> > > 
> > > Should we restrict this to python older than 2.6.5?
> > 
> > We could; I don't feel strongly about it, and this will only have an impact if we are actually autoinstalling things, which should only happen rarely.
> 
> Would you like me to restrict it?

It's up to you. I don't feel strongly. The main advantage of restricting IMO is that we can kill the code once we no longer support older pythons. Not a big deal in this case since it's a tiny amount of added complexity.
Comment 8 Dirk Pranke 2012-08-07 15:38:20 PDT
I'm not sure that adding an explicit version check gets you something that the fixme doesn't already get you; someone's still gonna have to grep for '2.6' or '2.6.1' and then do something. I'll leave it as it is for now since getting a useful python version string is mildly annoying :).
Comment 9 Dirk Pranke 2012-08-07 15:39:36 PDT
Committed r124928: <http://trac.webkit.org/changeset/124928>