Bug 93285 - MediaSource should use it's own list of source URLs
Summary: MediaSource should use it's own list of source URLs
Status: RESOLVED DUPLICATE of bug 91773
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Anna Cavender
URL:
Keywords:
Depends on: 93337
Blocks: 90819
  Show dependency treegraph
 
Reported: 2012-08-06 11:38 PDT by Anna Cavender
Modified: 2012-08-07 14:20 PDT (History)
3 users (show)

See Also:


Attachments
Patch (3.23 KB, patch)
2012-08-06 11:44 PDT, Anna Cavender
eric.carlson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anna Cavender 2012-08-06 11:38:16 PDT
r124780 was adding MediaSource objects to PublicURLManager's streamURLs list, piggy-backing on MEDIA_STREAM, which of course is no good.  This patch creates a sourceURLs list so that MediaSource can stand on its own.

Build failure that this fixes: http://build.webkit.org/builders/Chromium%20Android%20Release/builds/22977/steps/compile-webkit/logs/stdio
Comment 1 Anna Cavender 2012-08-06 11:44:30 PDT
Created attachment 156733 [details]
Patch
Comment 2 Anna Cavender 2012-08-06 13:43:44 PDT
Committed r124798: <http://trac.webkit.org/changeset/124798>
Comment 3 WebKit Review Bot 2012-08-06 22:45:00 PDT
Re-opened since this is blocked by 93337
Comment 4 Anna Cavender 2012-08-07 14:20:33 PDT
Marking as duplicate of 91773 because the changes here are now included in the patch on that bug.

*** This bug has been marked as a duplicate of bug 91773 ***