Bug 93192 - REGRESSION: PrettyPatchTest.test_pretty_diff_encodings has been failing on Chromium Windows
Summary: REGRESSION: PrettyPatchTest.test_pretty_diff_encodings has been failing on Ch...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-04 19:49 PDT by Ryosuke Niwa
Modified: 2013-04-08 14:10 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.58 KB, patch)
2012-08-07 19:50 PDT, Dirk Pranke
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2012-08-04 19:49:04 PDT
Checking autoinstalled packages ...
Checking imports ...
Finding the individual test methods ...
Running the tests ...
[101/1258] webkitpy.common.prettypatch_unittest.PrettyPatchTest.test_pretty_diff_encodings erred:
  Traceback (most recent call last):
    File "E:\b\chromium-win-release-tests\build\Tools\Scripts\webkitpy\common\prettypatch_unittest.py", line 73, in test_pretty_diff_encodings
      pretty = pretty_patch.pretty_diff(self._diff_with_multiple_encodings)
    File "E:\b\chromium-win-release-tests\build\Tools\Scripts\webkitpy\common\prettypatch.py", line 67, in pretty_diff
      return self._executive.run_command(args, input=diff, decode_output=False)
    File "E:\b\chromium-win-release-tests\build\Tools\Scripts\webkitpy\common\system\executive.py", line 423, in run_command
      (error_handler or self.default_error_handler)(script_error)
    File "E:\b\chromium-win-release-tests\build\Tools\Scripts\webkitpy\common\system\executive.py", line 340, in default_error_handler
      raise error
  ScriptError: Failed to run "['ruby', '-I', 'E:\\b\\chromium-win-release-tests\\build\\Websites\\bugs.webkit.org\\PrettyPatch'..." exit_code: 1
  
[874/1258] webkitpy.layout_tests.run_webkit_tests_integrationtest.MainTest.test_verbose_in_child_processes passed
Comment 1 Dirk Pranke 2012-08-07 19:48:09 PDT
Okay, so it is unfortunate that ScriptError is limiting the output here, but I reproduced this locally on Windows and PrettyPatch is actually failing (i.e., this is a real failure, not a problem w/ test-webkitpy or anything like that); it looks like some combination of the utf-8 encoding and line-ending conversion doesn't work.

I'm going to disable the test on win32 for now until we can actually fix the issue.
Comment 2 Dirk Pranke 2012-08-07 19:50:51 PDT
Created attachment 157090 [details]
Patch
Comment 3 Dirk Pranke 2012-08-07 19:53:03 PDT
Committed r124973: <http://trac.webkit.org/changeset/124973>
Comment 4 Dirk Pranke 2012-08-07 19:53:43 PDT
sigh .. didn't mean to close the bug. Test disabled in http://trac.webkit.org/changeset/124973 . Note that the patch I uploaded was missing an 'import sys', and I fixed that prior to landing.
Comment 5 Dirk Pranke 2012-08-08 15:37:05 PDT
reassigning owner to default, since I'm not dying to fix this myself ;).
Comment 6 Sergio Villar Senin 2012-09-19 09:20:06 PDT
I've just verified (because it was failing also in our WK2 gtk bot) that the problem here is the ruby version.

Our bot was running ruby 1.9.1 and we were able to get rid of the bug by downgrading it to 1.8.7.

I won't change the title of the bug until Dirk could verify that the problem in chromium win is the same (I'd bet it's)