Bug 93189 - [CMake] Add the ENSURE_MINIMUM_PACKAGE_VERSION macro.
Summary: [CMake] Add the ENSURE_MINIMUM_PACKAGE_VERSION macro.
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Raphael Kubo da Costa (:rakuco)
URL:
Keywords:
Depends on:
Blocks: 93191
  Show dependency treegraph
 
Reported: 2012-08-04 18:45 PDT by Raphael Kubo da Costa (:rakuco)
Modified: 2012-08-10 08:15 PDT (History)
8 users (show)

See Also:


Attachments
Patch (5.93 KB, patch)
2012-08-04 18:48 PDT, Raphael Kubo da Costa (:rakuco)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Kubo da Costa (:rakuco) 2012-08-04 18:45:59 PDT
[CMake] Add the ENSURE_MINIMUM_PACKAGE_VERSION macro.
Comment 1 Raphael Kubo da Costa (:rakuco) 2012-08-04 18:48:20 PDT
Created attachment 156544 [details]
Patch
Comment 2 Raphael Kubo da Costa (:rakuco) 2012-08-04 19:00:53 PDT
CC'ing a few CMake-interested people.
Comment 3 Patrick R. Gansterer 2012-08-05 12:13:43 PDT
Comment on attachment 156544 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=156544&action=review

> Source/cmake/WebKitMacros.cmake:265
> +# FIXME: This macro can be removed once we start depending on CMake 2.8.3, as we can use

which CMake version do you use?!?!? 2.8.2 is very old...
Comment 4 Raphael Kubo da Costa (:rakuco) 2012-08-05 16:21:19 PDT
Comment on attachment 156544 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=156544&action=review

>> Source/cmake/WebKitMacros.cmake:265
>> +# FIXME: This macro can be removed once we start depending on CMake 2.8.3, as we can use
> 
> which CMake version do you use?!?!? 2.8.2 is very old...

As I mentioned in <https://bugs.webkit.org/show_bug.cgi?id=93191#c5>, the problem is not the version I use, but the minimum one we require in the top-level CMakeLists.txt.
Comment 5 Patrick R. Gansterer 2012-08-05 21:36:10 PDT
(In reply to comment #4)
> (From update of attachment 156544 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=156544&action=review
> 
> >> Source/cmake/WebKitMacros.cmake:265
> >> +# FIXME: This macro can be removed once we start depending on CMake 2.8.3, as we can use
> > 
> > which CMake version do you use?!?!? 2.8.2 is very old...
> 
> As I mentioned in <https://bugs.webkit.org/show_bug.cgi?id=93191#c5>, the problem is not the version I use, but the minimum one we require in the top-level CMakeLists.txt.

Lets bump the version. I don't see much value in supporting such old CMake versions.
Comment 6 Thiago Marcos P. Santos 2012-08-05 21:47:46 PDT
Comment on attachment 156544 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=156544&action=review

>>>> Source/cmake/WebKitMacros.cmake:265
>>>> +# FIXME: This macro can be removed once we start depending on CMake 2.8.3, as we can use
>>> 
>>> which CMake version do you use?!?!? 2.8.2 is very old...
>> 
>> As I mentioned in <https://bugs.webkit.org/show_bug.cgi?id=93191#c5>, the problem is not the version I use, but the minimum one we require in the top-level CMakeLists.txt.
> 
> Lets bump the version. I don't see much value in supporting such old CMake versions.

+1 for bumping.
Comment 7 Raphael Kubo da Costa (:rakuco) 2012-08-05 23:11:35 PDT
(In reply to comment #5)
> Lets bump the version. I don't see much value in supporting such old CMake versions.

I'm OK with that, but I'd like to hear from Ming (already CC'ed) or anyone else from the BlackBerry team (I've CC'ed tonikitoo and Rob) first, as we need to know if they have any requirement to support CMake < 2.8.3.
Comment 8 Ming Xie 2012-08-07 08:18:41 PDT
(In reply to comment #7)
> (In reply to comment #5)
> > Lets bump the version. I don't see much value in supporting such old CMake versions.
> 
> I'm OK with that, but I'd like to hear from Ming (already CC'ed) or anyone else from the BlackBerry team (I've CC'ed tonikitoo and Rob) first, as we need to know if they have any requirement to support CMake < 2.8.3.

Currently our build machines still use 2.8.0. However, I don't want our BlackBerry port blocks this upgrade if 2.8.3 brings new features to the project.
Comment 9 Raphael Kubo da Costa (:rakuco) 2012-08-07 22:40:43 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #5)
> > > Lets bump the version. I don't see much value in supporting such old CMake versions.
> > 
> > I'm OK with that, but I'd like to hear from Ming (already CC'ed) or anyone else from the BlackBerry team (I've CC'ed tonikitoo and Rob) first, as we need to know if they have any requirement to support CMake < 2.8.3.
> 
> Currently our build machines still use 2.8.0. However, I don't want our BlackBerry port blocks this upgrade if 2.8.3 brings new features to the project.

Thank you for the response. I'll cook a new patch to bump our requirements then.
Comment 10 Gyuyoung Kim 2012-08-07 23:23:16 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #5)
> > > Lets bump the version. I don't see much value in supporting such old CMake versions.
> > 
> > I'm OK with that, but I'd like to hear from Ming (already CC'ed) or anyone else from the BlackBerry team (I've CC'ed tonikitoo and Rob) first, as we need to know if they have any requirement to support CMake < 2.8.3.
> 
> Currently our build machines still use 2.8.0. However, I don't want our BlackBerry port blocks this upgrade if 2.8.3 brings new features to the project.

As I mentioned in webkit-efl mailing list, it looks Tizen is using CMake 2.8.5. But, I also don't want to block to land this upgrade.
Comment 11 Raphael Kubo da Costa (:rakuco) 2012-08-08 01:35:40 PDT
(In reply to comment #9)
> Thank you for the response. I'll cook a new patch to bump our requirements then.

I have now filed bug 93450.
Comment 12 Raphael Kubo da Costa (:rakuco) 2012-08-10 08:15:27 PDT
Closing now that we require CMake 2.8.3 since <http://trac.webkit.org/changeset/125228>.