Bug 93014 - DOM4: className should be defined on Element and not on HTMLElement
Summary: DOM4: className should be defined on Element and not on HTMLElement
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Erik Arvidsson
URL:
Keywords: WebExposed
: 66284 93013 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-02 11:53 PDT by Erik Arvidsson
Modified: 2012-08-16 12:22 PDT (History)
9 users (show)

See Also:


Attachments
Patch (4.24 KB, patch)
2012-08-02 11:55 PDT, Erik Arvidsson
no flags Details | Formatted Diff | Diff
Patch for landing (5.14 KB, patch)
2012-08-02 12:59 PDT, Erik Arvidsson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Arvidsson 2012-08-02 11:53:53 PDT
DOM4: className should be defined on Element and not on HTMLElement
Comment 1 Erik Arvidsson 2012-08-02 11:55:04 PDT
Created attachment 156131 [details]
Patch
Comment 2 Adam Barth 2012-08-02 12:03:31 PDT
Comment on attachment 156131 [details]
Patch

Ok.  Looks like you might have some compile errors to work through.
Comment 3 Build Bot 2012-08-02 12:32:04 PDT
Comment on attachment 156131 [details]
Patch

Attachment 156131 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/13425330
Comment 4 Erik Arvidsson 2012-08-02 12:59:15 PDT
Created attachment 156146 [details]
Patch for landing
Comment 5 WebKit Review Bot 2012-08-02 14:28:29 PDT
Comment on attachment 156146 [details]
Patch for landing

Clearing flags on attachment: 156146

Committed r124499: <http://trac.webkit.org/changeset/124499>
Comment 6 WebKit Review Bot 2012-08-02 14:28:34 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Darin Adler 2012-08-03 14:48:30 PDT
Why no regression test? We could test this with SVG, I think.
Comment 8 Adam Barth 2012-08-03 14:52:39 PDT
(In reply to comment #7)
> Why no regression test? We could test this with SVG, I think.

Is there something more you think we should test other than fast/dom/Element/class-name.html in the patch?
Comment 9 HolgerJeromin 2012-08-06 12:44:27 PDT
*** Bug 66284 has been marked as a duplicate of this bug. ***
Comment 10 Alexey Proskuryakov 2012-08-07 15:55:11 PDT
This must have caused bug 93384.
Comment 11 Erik Arvidsson 2012-08-16 12:22:41 PDT
*** Bug 93013 has been marked as a duplicate of this bug. ***