Bug 92797 - gcc 4.7 complains uninitialized variable.
Summary: gcc 4.7 complains uninitialized variable.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Other
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 90669 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-31 15:38 PDT by Han Shen
Modified: 2012-11-15 05:27 PST (History)
3 users (show)

See Also:


Attachments
proposed patch (672 bytes, patch)
2012-07-31 15:39 PDT, Han Shen
haraken: review-
Details | Formatted Diff | Diff
Proposed patch - 2 (1.19 KB, patch)
2012-07-31 17:13 PDT, Han Shen
haraken: review-
Details | Formatted Diff | Diff
proposed patch - 3 (1.43 KB, patch)
2012-07-31 17:25 PDT, Han Shen
shenhan: commit-queue?
Details | Formatted Diff | Diff
Patch ready for landing ("Reviewer added to ChangeLog") (1.45 KB, patch)
2012-07-31 20:24 PDT, Han Shen
no flags Details | Formatted Diff | Diff
Patch ready for landing (1.46 KB, patch)
2012-07-31 20:25 PDT, Han Shen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Han Shen 2012-07-31 15:38:58 PDT
GCC 4.7 gives uninitialized value warning (treated as errors) against the following - 

  (a)
  uint32x2_t temporary1 = vset_lane_u32(*source, temporary1, 0);

This need to be fixed. The obvious way to do this is - 

  (b)
  uint32x2_t temporary1 = {0, 0};
  temporary1 = vset_lane_u32(*source, temporary1, 0);

(a) and (b) generates exactly the same asm. 

A patch is attached.
Comment 1 Han Shen 2012-07-31 15:39:38 PDT
Created attachment 155651 [details]
proposed patch
Comment 2 Kentaro Hara 2012-07-31 16:49:35 PDT
Comment on attachment 155651 [details]
proposed patch

ChangeLog is needed for any minor change.
Comment 3 Han Shen 2012-07-31 17:13:45 PDT
Created attachment 155683 [details]
Proposed patch - 2
Comment 4 Han Shen 2012-07-31 17:15:28 PDT
(In reply to comment #2)
> (From update of attachment 155651 [details])
> ChangeLog is needed for any minor change.

Hi kentaro, thanks! Uploaded a new patch with ChangeLog.
Comment 5 Kentaro Hara 2012-07-31 17:16:47 PDT
Comment on attachment 155683 [details]
Proposed patch - 2

View in context: https://bugs.webkit.org/attachment.cgi?id=155683&action=review

Please follow the normal ChangeLog format. You can refer to https://bugs.webkit.org/attachment.cgi?id=155661&action=review for example.

> Source/WebCore/ChangeLog:4
> +

- Bug URL.
- Simple explanation of your change.
- Tests. (You can just write "No tests. No change in behavior." in this case.)
Comment 6 Han Shen 2012-07-31 17:25:21 PDT
Created attachment 155686 [details]
proposed patch - 3
Comment 7 Han Shen 2012-07-31 17:26:18 PDT
(In reply to comment #5)
> (From update of attachment 155683 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=155683&action=review
> 
> Please follow the normal ChangeLog format. You can refer to https://bugs.webkit.org/attachment.cgi?id=155661&action=review for example.
> 
> > Source/WebCore/ChangeLog:4
> > +
> 
> - Bug URL.
> - Simple explanation of your change.
> - Tests. (You can just write "No tests. No change in behavior." in this case.)

Hi Kentaro, done, thanks!
Comment 8 Kentaro Hara 2012-07-31 17:29:07 PDT
Comment on attachment 155686 [details]
proposed patch - 3

Looks OK
Comment 9 Han Shen 2012-07-31 17:40:39 PDT
(In reply to comment #8)
> (From update of attachment 155686 [details])
> Looks OK

Does that mean I could proceed landing it? Or I need approval? Thanks!
Comment 10 Kentaro Hara 2012-07-31 17:42:09 PDT
Comment on attachment 155686 [details]
proposed patch - 3

Please change "cq " to "cq?" (at the right bottom of https://bugs.webkit.org/attachment.cgi?id=155686&action=review). Then I can change it to "cq+", by which the patch will be committed. (Already done for this patch.)
Comment 11 Han Shen 2012-07-31 17:44:48 PDT
(In reply to comment #10)
> (From update of attachment 155686 [details])
> Please change "cq " to "cq?" (at the right bottom of https://bugs.webkit.org/attachment.cgi?id=155686&action=review). Then I can change it to "cq+", by which the patch will be committed. (Already done for this patch.)

Thanks!
Comment 12 WebKit Review Bot 2012-07-31 19:53:45 PDT
Comment on attachment 155686 [details]
proposed patch - 3

Rejecting attachment 155686 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 1

ERROR: /mnt/git/webkit-commit-queue/Source/WebCore/ChangeLog neither lists a valid reviewer nor contains the string "Unreviewed" or "Rubber stamp" (case insensitive).

Full output: http://queues.webkit.org/results/13400672
Comment 13 Han Shen 2012-07-31 20:24:23 PDT
Created attachment 155712 [details]
Patch ready for landing ("Reviewer added to ChangeLog")
Comment 14 Han Shen 2012-07-31 20:25:47 PDT
Created attachment 155713 [details]
Patch ready for landing
Comment 15 WebKit Review Bot 2012-07-31 20:25:55 PDT
Comment on attachment 155713 [details]
Patch ready for landing

Rejecting attachment 155713 [details] from review queue.

shenhan@google.com does not have reviewer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have reviewer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have reviewer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your reviewer rights.
Comment 16 WebKit Review Bot 2012-07-31 20:26:35 PDT
Comment on attachment 155713 [details]
Patch ready for landing

Rejecting attachment 155713 [details] from commit-queue.

shenhan@google.com does not have committer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 17 WebKit Review Bot 2012-07-31 20:27:52 PDT
Comment on attachment 155713 [details]
Patch ready for landing

Rejecting attachment 155713 [details] from commit-queue.

shenhan@google.com does not have committer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 18 WebKit Review Bot 2012-07-31 20:29:34 PDT
Comment on attachment 155713 [details]
Patch ready for landing

Rejecting attachment 155713 [details] from commit-queue.

shenhan@google.com does not have committer permissions according to http://trac.webkit.org/browser/trunk/Tools/Scripts/webkitpy/common/config/committers.py.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in Tools/Scripts/webkitpy/common/config/committers.py by adding yourself to the file (no review needed).  The commit-queue restarts itself every 2 hours.  After restart the commit-queue will correctly respect your committer rights.
Comment 19 WebKit Review Bot 2012-07-31 20:50:55 PDT
Comment on attachment 155686 [details]
proposed patch - 3

Cleared Kentaro Hara's review+ from obsolete attachment 155686 [details] so that this bug does not appear in http://webkit.org/pending-commit.
Comment 20 WebKit Review Bot 2012-07-31 20:50:58 PDT
Comment on attachment 155712 [details]
Patch ready for landing ("Reviewer added to ChangeLog")

Cleared review+ from obsolete attachment 155712 [details] so that this bug does not appear in http://webkit.org/pending-commit.
Comment 21 Han Shen 2012-08-01 09:00:44 PDT
(In reply to comment #10)
> (From update of attachment 155686 [details])
> Please change "cq " to "cq?" (at the right bottom of https://bugs.webkit.org/attachment.cgi?id=155686&action=review). Then I can change it to "cq+", by which the patch will be committed. (Already done for this patch.)

Hi Kentaro, sorry, I had to add "Reviewed by - " to the ChangeLog, could you do that "cq+" again?

Thanks,
-Han
Comment 22 Kentaro Hara 2012-08-01 09:01:12 PDT
Done.
Comment 23 Han Shen 2012-08-01 09:13:44 PDT
(In reply to comment #22)
> Done.

That's super fast, thanks!
Comment 24 WebKit Review Bot 2012-08-01 10:37:32 PDT
Comment on attachment 155713 [details]
Patch ready for landing

Clearing flags on attachment: 155713

Committed r124341: <http://trac.webkit.org/changeset/124341>
Comment 25 WebKit Review Bot 2012-08-01 10:37:37 PDT
All reviewed patches have been landed.  Closing bug.
Comment 26 Gabor Rapcsanyi 2012-11-15 05:27:40 PST
*** Bug 90669 has been marked as a duplicate of this bug. ***