Bug 9266 - Quirksmode: Setting location.hash to the same value twice causes reload
Summary: Quirksmode: Setting location.hash to the same value twice causes reload
Status: RESOLVED DUPLICATE of bug 6309
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: PC OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.howtocreate.co.uk/safari/l...
Keywords:
Depends on:
Blocks: 9610
  Show dependency treegraph
 
Reported: 2006-06-02 14:56 PDT by Adele Peterson
Modified: 2006-06-02 20:51 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adele Peterson 2006-06-02 14:56:49 PDT
http://www.quirksmode.org/bugreports/archives/safari/index.html

"Setting location.hash to the same value twice in succession causes the page to reload.

(ppknote: This bug is closely related to "Using internal link triggers load event", but it's not quite the same.)

Test page http://www.howtocreate.co.uk/safari/locationHashBug.html
Workaround is included
Reported by: TarquinWJ."
Comment 1 David Kilzer (:ddkilzer) 2006-06-02 15:30:56 PDT
This may have been fixed with the patch for Bug 6309.  Testing needed.
Comment 2 David Kilzer (:ddkilzer) 2006-06-02 20:51:00 PDT
Fixed with Bug 6309.


*** This bug has been marked as a duplicate of 6309 ***