Bug 92540 - Web Inspector: workers inspector is broken in the remote debugging mode
Summary: Web Inspector: workers inspector is broken in the remote debugging mode
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Pavel Feldman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-27 13:03 PDT by Pavel Feldman
Modified: 2012-07-30 01:58 PDT (History)
12 users (show)

See Also:


Attachments
Patch (1.60 KB, patch)
2012-07-27 13:09 PDT, Pavel Feldman
no flags Details | Formatted Diff | Diff
Patch (2.45 KB, patch)
2012-07-27 13:50 PDT, Pavel Feldman
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Feldman 2012-07-27 13:03:18 PDT
The problem is that worker manager re-uses complete url with query parameters for spin-off worker front-ends. In case of remote debugging, newly created front-end attempts to connect to the same web socket (because of the ws parameter).
Comment 1 Pavel Feldman 2012-07-27 13:09:55 PDT
Created attachment 155035 [details]
Patch
Comment 2 Pavel Feldman 2012-07-27 13:50:44 PDT
Created attachment 155042 [details]
Patch
Comment 3 WebKit Review Bot 2012-07-30 01:58:00 PDT
Comment on attachment 155042 [details]
Patch

Clearing flags on attachment: 155042

Committed r124005: <http://trac.webkit.org/changeset/124005>
Comment 4 WebKit Review Bot 2012-07-30 01:58:05 PDT
All reviewed patches have been landed.  Closing bug.