Bug 92449 - [Tests] Rename fast/forms/{number,time}/*-validity-state-* to *-validity-*
Summary: [Tests] Rename fast/forms/{number,time}/*-validity-state-* to *-validity-*
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: yosin
Depends on:
Reported: 2012-07-26 19:25 PDT by yosin
Modified: 2012-07-26 21:08 PDT (History)
1 user (show)

See Also:

Patch (9.56 KB, patch)
2012-07-26 20:27 PDT, yosin
no flags Details | Formatted Diff | Diff
Patch 2 (72.15 KB, patch)
2012-07-26 20:59 PDT, yosin
tkent: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yosin 2012-07-26 19:25:17 PDT
For consistency, number-validitystate-range-overflow.html should be number-validity-state-range-overflow.html.
Sorry, I missed this renaming at r123302.
Comment 1 yosin 2012-07-26 20:27:58 PDT
Created attachment 154823 [details]
Comment 2 yosin 2012-07-26 20:29:16 PDT
Comment on attachment 154823 [details]

Could you review this patch?
Thanks in advance.

The "Diff" is result of "svn move" command.
Comment 3 Kent Tamura 2012-07-26 20:37:58 PDT
I overlooked an issue of the previous patch.
I don't think they should be named as number-validity-state-*.html.  They test 'validity' IDL attribute of number input element, or they test 'ValidityState' DOM interface for number input element.  

I prefer number-validity-rangeOverflow.html because it matches IDL attribute names, or number-validity-rangeoverflow.html if you like lowercase.
Comment 4 yosin 2012-07-26 20:55:12 PDT
Renamed obey following rules:
1. Use lower case letters only. mixing case letters may cause some issue in Windows.
2 No dash for IDL attribute name. We've been using "valueasnumber", "stepup", "stepdown" and so on.
Comment 5 yosin 2012-07-26 20:59:48 PDT
Created attachment 154826 [details]
Patch 2
Comment 6 yosin 2012-07-26 21:01:52 PDT
Comment on attachment 154826 [details]
Patch 2

Could you review this patch?
Thanks in advance.
Note: The "Diff" is result of "svn move".

= Changes since the last review =
* Rename *-validity-state-*- to *-validity-* for fast/forms/number and fast/forms/time
Comment 7 Kent Tamura 2012-07-26 21:04:19 PDT
Comment on attachment 154826 [details]
Patch 2

ok, thanks.
Comment 8 yosin 2012-07-26 21:08:45 PDT
Landed: http://trac.webkit.org/changeset/123836