Bug 91713 - Web Inspector: Elements: find by selector
Summary: Web Inspector: Elements: find by selector
Status: RESOLVED DUPLICATE of bug 86196
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P5 Enhancement
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-18 22:53 PDT by Randall Farmer
Modified: 2012-07-19 00:29 PDT (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Randall Farmer 2012-07-18 22:53:10 PDT
When I type '#foo' in the Search Elements box, I get the results of a full-text search for #foo, and not the element with id="foo". I'm probably not the only one to try using selectors to search. 

There are lots of ways selector search could be tied in:

The box could try feeding the search to querySelector before falling back to its current fulltext search if no results are found. It could choose between querySelector and fulltext search based on whether the search string "looks like" certain common kinds of selector (e.g., if it matches /^\w*[\.\#\[]\w+/). It could always yield both fulltext search results and any selector matches. 

Or there could be some distinct UI for searching by selector: a keystroke+additional toolbar like the one for "search all scripts", or a UI that temporarily puts a selector search box where the breadcrumb bar is now (maybe prepopulated with a selector based on any highlighted element).

I don't know the first thing about how it should be done, of course, just noting interest in doing it any way at all.
Comment 1 Pavel Feldman 2012-07-19 00:29:08 PDT

*** This bug has been marked as a duplicate of bug 86196 ***