Bug 9127 - Invoke capturing event listeners when AT_TARGET
: Invoke capturing event listeners when AT_TARGET
Status: RESOLVED FIXED
: WebKit
HTML DOM
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To:
:
:
:
: 7788
  Show dependency treegraph
 
Reported: 2006-05-26 11:33 PST by
Modified: 2006-06-04 10:07 PST (History)


Attachments
Patch (4.81 KB, patch)
2006-05-26 11:46 PST, Anders Carlsson
andersca: review-
Review Patch | Details | Formatted Diff | Diff
Better approach (4.79 KB, patch)
2006-05-26 12:00 PST, Anders Carlsson
ggaren: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-05-26 11:33:23 PST
This is contrary to the DOM 2 spec which says that

"A capturing EventListener will not be triggered by events dispatched directly to the EventTarget upon which it is registered."

However, Mozilla invokes capturing event listeners when AT_TARGET and live.com (at least) depends on that so we should do it too
------- Comment #1 From 2006-05-26 11:42:54 PST -------
We used to work this way actually, so this is actually a regression from Safari 1.2.  I added code back in 1.2 to make sure we did capturing, then a capture at target, then a bubble at target, then bubbling.  At some point the capture at the target must have been removed.
------- Comment #2 From 2006-05-26 11:46:14 PST -------
Created an attachment (id=8555) [details]
Patch
------- Comment #3 From 2006-05-26 11:51:09 PST -------
(From update of attachment 8555 [details])
I'll dig up the way hyatt implemented it and use that
------- Comment #4 From 2006-05-26 12:00:21 PST -------
Created an attachment (id=8557) [details]
Better approach
------- Comment #5 From 2006-05-26 13:09:12 PST -------
(From update of attachment 8557 [details])
I'm marking this r+ after talking with Anders and Maciej. We want to emulate the Firefox to support live.com.

The Firefox bugzilla about this is: https://bugzilla.mozilla.org/show_bug.cgi?id=235441.
------- Comment #6 From 2006-05-27 14:49:50 PST -------
Maciej, weren't you guys planning to not do this? This seems wrong.
------- Comment #7 From 2006-06-04 10:07:38 PST -------
*** Bug 7205 has been marked as a duplicate of this bug. ***