Bug 90914 - [Chromium] REGRESSION(r121909): m_currentInputEvent never set
Summary: [Chromium] REGRESSION(r121909): m_currentInputEvent never set
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Adam Klein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-10 15:40 PDT by Adam Klein
Modified: 2012-07-10 18:13 PDT (History)
2 users (show)

See Also:


Attachments
Patch (1.65 KB, patch)
2012-07-10 15:42 PDT, Adam Klein
no flags Details | Formatted Diff | Diff
Patch (1.94 KB, patch)
2012-07-10 15:47 PDT, Adam Klein
inferno: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Klein 2012-07-10 15:40:37 PDT
[Chromium] REGRESSION(r121909): m_currentInputEvent never set
Comment 1 Adam Klein 2012-07-10 15:42:25 PDT
Created attachment 151539 [details]
Patch
Comment 2 Adam Klein 2012-07-10 15:47:01 PDT
Created attachment 151541 [details]
Patch
Comment 3 Vincent Scheib 2012-07-10 15:49:20 PDT
Can we manufacture a test verifying the correct behavior of window.open?
Comment 4 Adam Klein 2012-07-10 15:52:22 PDT
(In reply to comment #3)
> Can we manufacture a test verifying the correct behavior of window.open?

That would be great, but I'm not sure this can be done as a layout test. Does DRT expose anything regarding "background" vs "foreground" "tabs"?
Comment 5 Adam Klein 2012-07-10 15:54:51 PDT
Landing for now, as the code it's fixing is brand new and clearly wrong. Will poke around to see about adding a test in the meantime.
Comment 6 Vincent Scheib 2012-07-10 16:10:07 PDT
Thx for catching & fixing. Chat w/ Darin indicates that this is a painful bit of code to test in webkit, as DRT likely doesn't have concepts such as tabs, or logic to have it be foreground or background.  Easiest test coverage may be via a browser test. I've created a chrome issue for that, since we don't know where the test should be implemented yet. https://code.google.com/p/chromium/issues/detail?id=136614
Comment 7 Adam Klein 2012-07-10 18:13:24 PDT
Committed r122284: <http://trac.webkit.org/changeset/122284>