Bug 90765 - garden-o-matic should refuse rebaseline for reftests
: garden-o-matic should refuse rebaseline for reftests
Status: RESOLVED DUPLICATE of bug 101976
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Alan Cutter
:
Depends on:
Blocks: 69227
  Show dependency treegraph
 
Reported: 2012-07-09 02:13 PDT by Hayato Ito
Modified: 2012-12-20 19:12 PST (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hayato Ito 2012-07-09 02:13:59 PDT
It might be user-friendly if garden-o-matic can refuse rebaseline for reftests.
Comment 1 Adam Barth 2012-07-09 08:50:40 PDT
Yes!  We don't have a good meta bug to collect these feature requests, but Bug 69227 will have to do for now.
Comment 2 Ojan Vafai 2012-07-09 09:23:09 PDT
It should already do hide the rebaseline button for reftests. Did you see a case where it doesn't?

Oh, on the main page where tests are grouped together, I suppose it still shows the rebaseline button. I was thinking that we actually need to make webkit-patch be a noop for rebaselining reftests. Fixing it at that level is better because it means that other users of the webkit-patch command will also be safe.
Comment 3 Hayato Ito 2012-07-09 16:02:38 PDT
(In reply to comment #2)
> It should already do hide the rebaseline button for reftests. Did you see a case where it doesn't?

Yes. Yesterday, when I was gardening, I saw 'Rebaseline' button for a single test, 'fast/text-autosizing/simple-paragraph.html' on the main page.  It was not grouped. As far as I remembered, I clicked a 'Rebaseline' button for the test, and I noticed it was a reftest after a patch was created by garden-o-matic.

> 
> Oh, on the main page where tests are grouped together, I suppose it still shows the rebaseline button. I was thinking that we actually need to make webkit-patch be a noop for rebaselining reftests. Fixing it at that level is better because it means that other users of the webkit-patch command will also be safe.

That sounds nice. webkit-patch is a good place as a last defense.
Comment 4 Tony Chang 2012-12-20 19:12:38 PST
This was recently fixed.

*** This bug has been marked as a duplicate of bug 101976 ***