Bug 90754 - Layout Test storage/indexeddb/mozilla/key-requirements.html is flaky
Summary: Layout Test storage/indexeddb/mozilla/key-requirements.html is flaky
Status: RESOLVED DUPLICATE of bug 90469
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-08 23:49 PDT by Hayato Ito
Modified: 2012-07-10 13:26 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hayato Ito 2012-07-08 23:49:07 PDT
The following layout test is flaky on WebKit Win.

storage/indexeddb/mozilla/key-requirements.html

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=storage%2Findexeddb%2Fmozilla%2Fkey-requirements.html

Probable cause:
I cannot tell an exact revision from blame list at first glace.

WebKit blamelist:
http://trac.webkit.org/log/?verbose=on&rev=121987&stop_rev=121985
Chrome blamelist:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&mode=html&range=145607:145601
Comment 1 Joshua Bell 2012-07-09 15:17:42 PDT
Probably dupe of 90469
Comment 2 Joshua Bell 2012-07-09 15:18:31 PDT

*** This bug has been marked as a duplicate of bug 90469 ***
Comment 3 Rafael Weinstein 2012-07-10 13:24:31 PDT
Actually, it looks like all but a few indexeddb/mozilla tests are flaky and crashing. I've marked most of them as PASS CRASH in TestExpectations in r122254.
Comment 4 Joshua Bell 2012-07-10 13:26:58 PDT
(In reply to comment #3)
> Actually, it looks like all but a few indexeddb/mozilla tests are flaky and crashing. I've marked most of them as PASS CRASH in TestExpectations in r122254.

See http://webkit.org/b/90469

The cause does not appear to be in IDB itself, but something about the style of IDB tests (async, script based) it making them prone to hit it. This will probably affect most of the storage/indexeddb tests, so feel free to mark as many of those PASS CRASH as necessary until 90469 is addressed.