Bug 90708 - fullscreen/exit-full-screen-iframe.html is failing
Summary: fullscreen/exit-full-screen-iframe.html is failing
Status: RESOLVED DUPLICATE of bug 139779
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P2 Normal
Assignee: Nobody
URL:
Keywords: LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2012-07-06 16:10 PDT by Filip Pizlo
Modified: 2014-12-18 10:51 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2012-07-06 16:10:57 PDT
This test is failing:


--- /Volumes/Data/pizlo/secondary/OpenSource/WebKitBuild/Debug/layout-test-results/fullscreen/exit-full-screen-iframe-expected.txt
+++ /Volumes/Data/pizlo/secondary/OpenSource/WebKitBuild/Debug/layout-test-results/fullscreen/exit-full-screen-iframe-actual.txt
@@ -5,6 +5,6 @@
 EVENT(webkitfullscreenchange)
 TEST(document.getElementById('frame').contentDocument.webkitIsFullScreen==true) OK
 EVENT(webkitfullscreenchange)
-TEST(document.getElementById('frame').contentDocument.webkitIsFullScreen==false) OK
+TEST(document.getElementById('frame').contentDocument.webkitIsFullScreen==false) FAIL
 END OF TEST
Comment 1 Filip Pizlo 2012-07-06 16:15:14 PDT
Skipped in http://trac.webkit.org/changeset/122040
Comment 2 Alexey Proskuryakov 2012-07-07 01:27:16 PDT
Also fails on chromium: bug 90704. Should r122035 be just rolled out?

Filip, please be sure to CC responsible parties when skipping tests.
Comment 3 Max Feil 2012-07-07 13:38:44 PDT
(In reply to comment #2)
> Also fails on chromium: bug 90704. Should r122035 be just rolled out?

I believe this test should pass, and that the failure indicates a real problem that needs to be investigated.

After webkitCancelFullScreen() is called from JavaScript and the resulting webkitfullscreenchange event is received, webkitIsFullScreen should no longer be true.

Rolling out r122035 would revert the failing test, but it would also revert a valid BlackBerry code fix.
Comment 4 Max Feil 2012-07-07 14:15:29 PDT
(In reply to comment #2)
> Also fails on chromium: bug 90704.

Note that this test causes EFL and GTK ports to crash, which is are real failures that need to be fixed. See also bug 89817 for my attempt at a patch which would have prevent these crashes but did not pass review.
Comment 5 Max Feil 2012-07-07 20:22:18 PDT
(In reply to comment #4)
> Note that this test causes EFL and GTK ports to crash

GTK port crash is now fixed (bug 90719) and this test passes on GTK (see http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release/ ).
Comment 6 Antonio Gomes 2012-07-08 21:04:47 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > Note that this test causes EFL and GTK ports to crash
> 
> GTK port crash is now fixed (bug 90719) and this test passes on GTK (see http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release/ ).

EFL is also fixed in trunk.
Comment 7 Eric Carlson 2013-08-08 11:35:55 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > Note that this test causes EFL and GTK ports to crash
> > 
> > GTK port crash is now fixed (bug 90719) and this test passes on GTK (see http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release/ ).
> 
> EFL is also fixed in trunk.

This test passes on the Mac port as well: http://build.webkit.org/results/Apple%20MountainLion%20Debug%20WK2%20(Tests)/r153825%20(11521)/results.html

Un-skipped in https://trac.webkit.org/r153834 .

Marking bug as RESOLVED/WORKSFORME.
Comment 8 Eric Carlson 2013-08-08 14:16:29 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > (In reply to comment #4)
> > > > Note that this test causes EFL and GTK ports to crash
> > > 
> > > GTK port crash is now fixed (bug 90719) and this test passes on GTK (see http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release/ ).
> > 
> > EFL is also fixed in trunk.
> 
> This test passes on the Mac port as well: http://build.webkit.org/results/Apple%20MountainLion%20Debug%20WK2%20(Tests)/r153825%20(11521)/results.html
> 
> Un-skipped in https://trac.webkit.org/r153834 .
> 
> Marking bug as RESOLVED/WORKSFORME.

Actually the test is flakey on both Mac and EFL ports. Marked as flakey on Mac in https://trac.webkit.org/r153846.
Comment 9 Alexey Proskuryakov 2014-12-18 10:51:53 PST

*** This bug has been marked as a duplicate of bug 139779 ***