Bug 90536 - XHR.send should support ArrayBufferView
Summary: XHR.send should support ArrayBufferView
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kinuko Yasuda
URL:
Keywords:
Depends on:
Blocks: 85961
  Show dependency treegraph
 
Reported: 2012-07-04 02:42 PDT by Kinuko Yasuda
Modified: 2012-07-11 00:51 PDT (History)
8 users (show)

See Also:


Attachments
Patch (10.93 KB, patch)
2012-07-04 02:46 PDT, Kinuko Yasuda
kbr: review+
Details | Formatted Diff | Diff
for submit (10.67 KB, patch)
2012-07-06 00:19 PDT, Kinuko Yasuda
no flags Details | Formatted Diff | Diff
for submit (fixed histogram name) (10.68 KB, patch)
2012-07-06 00:48 PDT, Kinuko Yasuda
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kinuko Yasuda 2012-07-04 02:42:42 PDT
XHR.send should support ArrayBufferView and also eventually deprecate ArrayBuffer
Comment 1 Kinuko Yasuda 2012-07-04 02:46:43 PDT
Created attachment 150748 [details]
Patch
Comment 2 Kenneth Russell 2012-07-04 08:41:15 PDT
Comment on attachment 150748 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=150748&action=review

Looks good overall. A couple of minor comments which you can fix upon landing. r=me

> Source/WebCore/xml/XMLHttpRequest.cpp:661
> +    HistogramSupport::histogramEnumeration("WebCore.XHR.send.ArrayBufferView", XMLHttpRequestSendArrayBuffer, XMLHttpRequestSendArrayBufferEnumMax);

The naming of this histogram is a little confusing. Consider naming it something like send.ArrayBufferOrView, here and below.

> Source/WebCore/xml/XMLHttpRequest.cpp:686
> +    }

This code is essentially duplicated; please consider factoring it and the body of send(ArrayBuffer, ...) into a helper method taking (void*, unsigned) as arguments.
Comment 3 Kinuko Yasuda 2012-07-06 00:19:11 PDT
Created attachment 151025 [details]
for submit
Comment 4 Kinuko Yasuda 2012-07-06 00:48:21 PDT
Created attachment 151027 [details]
for submit (fixed histogram name)
Comment 5 Kenneth Russell 2012-07-06 10:40:29 PDT
Comment on attachment 151027 [details]
for submit (fixed histogram name)

Looks good. r=me (even though this one wasn't marked r?)
Comment 6 WebKit Review Bot 2012-07-08 20:09:26 PDT
Comment on attachment 151027 [details]
for submit (fixed histogram name)

Clearing flags on attachment: 151027

Committed r122074: <http://trac.webkit.org/changeset/122074>
Comment 7 Yuta Kitamura 2012-07-11 00:51:31 PDT
Seems like we can close this bug as resolved.