Bug 90332 - [GTK] Need to bump libsoup requirements (for `soup_cookie_jar_get_cookie_list`)
Summary: [GTK] Need to bump libsoup requirements (for `soup_cookie_jar_get_cookie_list`)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-30 00:48 PDT by Priit Laes (IRC: plaes)
Modified: 2012-07-03 08:48 PDT (History)
4 users (show)

See Also:


Attachments
webkit-bump-libsoup-to-2-39-3.patch (1.42 KB, patch)
2012-06-30 00:52 PDT, Priit Laes (IRC: plaes)
gns: commit-queue-
Details | Formatted Diff | Diff
webkit-bump-libsoup-to-2-39-2.patch (1.42 KB, patch)
2012-06-30 01:08 PDT, Priit Laes (IRC: plaes)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Priit Laes (IRC: plaes) 2012-06-30 00:48:53 PDT
Getting following error when trying to build master:

[snip]
Source/WebCore/platform/network/soup/CookieJarSoup.cpp: In function ‘void WebCore::setCookies(WebCore::Document*, const WebCore::KURL&, const WTF::String&)’:
Source/WebCore/platform/network/soup/CookieJarSoup.cpp:99:86: error: ‘soup_cookie_jar_get_cookie_list’ was not declared in this scope
Source/WebCore/platform/network/soup/CookieJarSoup.cpp:117:92: error: ‘soup_cookie_jar_add_cookie_with_first_party’ was not declared in this scope
[/snip]
Comment 1 Priit Laes (IRC: plaes) 2012-06-30 00:52:31 PDT
Created attachment 150310 [details]
webkit-bump-libsoup-to-2-39-3.patch
Comment 2 Gustavo Noronha (kov) 2012-06-30 01:02:44 PDT
Comment on attachment 150310 [details]
webkit-bump-libsoup-to-2-39-3.patch

Attachment 150310 [details] did not pass gtk-ews (gtk):
Output: http://queues.webkit.org/results/13110630
Comment 3 Priit Laes (IRC: plaes) 2012-06-30 01:04:36 PDT
(In reply to comment #2)
> (From update of attachment 150310 [details])
> Attachment 150310 [details] did not pass gtk-ews (gtk):
> Output: http://queues.webkit.org/results/13110630

> checking for LIBSOUP... no
> configure: error: Package requirements (libsoup-2.4 >= 2.39.3) were not met:
> 
> Requested 'libsoup-2.4 >= 2.39.3' but version of libsoup is 2.39.2

soup_cookie_jar_add_cookie_with_first_party() was added in 2.39.3
Comment 4 Priit Laes (IRC: plaes) 2012-06-30 01:08:08 PDT
Created attachment 150311 [details]
webkit-bump-libsoup-to-2-39-2.patch
Comment 5 Chris Dumez 2012-06-30 01:40:33 PDT
Comment on attachment 150311 [details]
webkit-bump-libsoup-to-2-39-2.patch

LGTM. Sorry I forgot to do that.
Comment 6 WebKit Review Bot 2012-07-03 08:48:54 PDT
Comment on attachment 150311 [details]
webkit-bump-libsoup-to-2-39-2.patch

Clearing flags on attachment: 150311

Committed r121772: <http://trac.webkit.org/changeset/121772>
Comment 7 WebKit Review Bot 2012-07-03 08:48:59 PDT
All reviewed patches have been landed.  Closing bug.