Bug 90262 - [Qt][WTR] Get rid of using DumpRenderTreeSupportQt
Summary: [Qt][WTR] Get rid of using DumpRenderTreeSupportQt
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
: 90346 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-29 02:41 PDT by Balazs Kelemen
Modified: 2014-01-29 09:09 PST (History)
11 users (show)

See Also:


Attachments
Patch (3.51 KB, patch)
2012-06-29 04:20 PDT, Balazs Kelemen
no flags Details | Formatted Diff | Diff
Patch (4.41 KB, patch)
2012-07-25 11:52 PDT, Balazs Kelemen
no flags Details | Formatted Diff | Diff
Patch (5.63 KB, patch)
2012-08-01 01:16 PDT, Balazs Kelemen
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Balazs Kelemen 2012-06-29 02:41:53 PDT
The only reason why we use it in some place is the v8 support. Now that we are over with it we can remove these.
Comment 1 Balazs Kelemen 2012-06-29 04:20:02 PDT
Created attachment 150134 [details]
Patch
Comment 2 Balazs Kelemen 2012-06-29 05:05:39 PDT
Comment on attachment 150134 [details]
Patch

Clearing flags on attachment: 150134

Committed r121550: <http://trac.webkit.org/changeset/121550>
Comment 3 Balazs Kelemen 2012-06-29 05:05:46 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Balazs Kelemen 2012-07-03 10:37:26 PDT
Reverted in r121788. Need to fix some issues of the Qt build system before relanding this.
Comment 5 Balazs Kelemen 2012-07-25 09:16:36 PDT
*** Bug 90346 has been marked as a duplicate of this bug. ***
Comment 6 Balazs Kelemen 2012-07-25 11:52:24 PDT
Created attachment 154410 [details]
Patch
Comment 7 Early Warning System Bot 2012-07-25 13:09:00 PDT
Comment on attachment 154410 [details]
Patch

Attachment 154410 [details] did not pass qt-wk2-ews (qt):
Output: http://queues.webkit.org/results/13342356
Comment 8 Simon Hausmann 2012-07-26 07:56:27 PDT
Comment on attachment 154410 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=154410&action=review

I think the patch is good, I like this approach. But it appears to break the Gtk build, the EWS failure seems valid.

> Source/WebCore/ChangeLog:3
> +        [Qt][WTR] Get rid of using DumpRenderTreeSupportQt

I think the title is a bit generic, what about renaming it to "Get rid of DumpRenderTreeSupportQt::injectInternals wrapper"?
Comment 9 Balazs Kelemen 2012-08-01 01:16:50 PDT
Created attachment 155747 [details]
Patch
Comment 10 Build Bot 2012-08-01 02:08:15 PDT
Comment on attachment 155747 [details]
Patch

Attachment 155747 [details] did not pass win-ews (win):
Output: http://queues.webkit.org/results/13400755
Comment 11 Build Bot 2012-08-01 02:59:20 PDT
Comment on attachment 155747 [details]
Patch

Attachment 155747 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/13393977
Comment 12 Build Bot 2012-08-01 03:17:29 PDT
Comment on attachment 155747 [details]
Patch

Attachment 155747 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/13417118
Comment 13 Balazs Kelemen 2012-08-01 05:11:17 PDT
Adding WEBCORE_TESTING to WebCoreTestSupport::injectInternalsObject and WebCoreTestSupport::resetInternalsObject breaks the win build. It needs the symbol "__declspec(dllimport) void __cdecl WebCoreTestSupport::injectInternalsObject(struct OpaqueJSContext const *)" in DRT but it doesn't find it. It seems strange to me because dllimport should be the right here to do from DRT. Idea?
Comment 14 Hajime Morrita 2012-08-01 17:41:01 PDT
(In reply to comment #13)
> Adding WEBCORE_TESTING to WebCoreTestSupport::injectInternalsObject and WebCoreTestSupport::resetInternalsObject breaks the win build. It needs the symbol "__declspec(dllimport) void __cdecl WebCoreTestSupport::injectInternalsObject(struct OpaqueJSContext const *)" in DRT but it doesn't find it. It seems strange to me because dllimport should be the right here to do from DRT. Idea?

WEBCORE_TESTING isn't ready yet. I'm sorry for the inconvenience,
Comment 15 Balazs Kelemen 2012-08-03 04:32:25 PDT
(In reply to comment #14)
> (In reply to comment #13)
> > Adding WEBCORE_TESTING to WebCoreTestSupport::injectInternalsObject and WebCoreTestSupport::resetInternalsObject breaks the win build. It needs the symbol "__declspec(dllimport) void __cdecl WebCoreTestSupport::injectInternalsObject(struct OpaqueJSContext const *)" in DRT but it doesn't find it. It seems strange to me because dllimport should be the right here to do from DRT. Idea?
> 
> WEBCORE_TESTING isn't ready yet. I'm sorry for the inconvenience,

I'm a bit confused how to proceed with this. I don't want to add a new platform specific define because WEBCORE_TESTING is supposed to serve for this Could you describe what is missing and how could those symbols note become exported?
Comment 16 Balazs Kelemen 2013-01-27 14:45:54 PST
I could not take care about this in the foreseeable future so feel free to pick it.