Bug 89982 - On Mac, autocorrection sometimes fails to take place in Safari.
Summary: On Mac, autocorrection sometimes fails to take place in Safari.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.7
: P2 Normal
Assignee: Jia Pu
URL:
Keywords: InRadar
Depends on: 90056
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 08:35 PDT by Jia Pu
Modified: 2012-07-11 15:50 PDT (History)
8 users (show)

See Also:


Attachments
Patch. (1.94 KB, patch)
2012-06-26 09:05 PDT, Jia Pu
no flags Details | Formatted Diff | Diff
Revised patch. (2.83 KB, patch)
2012-06-27 11:00 PDT, Jia Pu
rniwa: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jia Pu 2012-06-26 08:35:40 PDT
This bug was introduced months ago, when spelling checking related code was being moved around. I haven't been able to nail down exactly which commit.

<rdar://problem/11740064>
Comment 1 Jia Pu 2012-06-26 09:05:40 PDT
Created attachment 149540 [details]
Patch.
Comment 2 Darin Adler 2012-06-26 10:54:03 PDT
Comment on attachment 149540 [details]
Patch.

Can we make a regression test for this? What prevents this from getting reintroduced next time someone refactors?
Comment 3 Darin Adler 2012-06-26 10:54:32 PDT
(In reply to comment #2)
> Can we make a regression test for this?

Oh, I see your comment now. There is a regression test for this, but it’s turned off!
Comment 4 WebKit Review Bot 2012-06-26 11:39:15 PDT
Comment on attachment 149540 [details]
Patch.

Clearing flags on attachment: 149540

Committed r121271: <http://trac.webkit.org/changeset/121271>
Comment 5 WebKit Review Bot 2012-06-26 11:39:26 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Vicki Pfau 2012-06-26 15:32:07 PDT
This change has been causing test regressions in Safari on many editing, selection, pasteboard and spell checking tests.
Comment 7 Ryosuke Niwa 2012-06-27 02:08:21 PDT
This patch caused 12+ tests to fail on Lion:
http://build.webkit.org/results/Apple%20Lion%20Debug%20WK1%20(Tests)/r121275%20(405)/results.html
Comment 8 Ryosuke Niwa 2012-06-27 02:08:35 PDT
I think we need to roll this patch out.
Comment 9 WebKit Review Bot 2012-06-27 02:20:01 PDT
Re-opened since this is blocked by 90056
Comment 10 Jia Pu 2012-06-27 11:00:27 PDT
Created attachment 149774 [details]
Revised patch.
Comment 11 Ryosuke Niwa 2012-07-04 14:24:42 PDT
Comment on attachment 149774 [details]
Revised patch.

View in context: https://bugs.webkit.org/attachment.cgi?id=149774&action=review

> Source/WebCore/ChangeLog:5
> +        Bug 89982 - On Mac, autocorrection sometimes fails to take place in Safari.
> +
> +        On Mac, autocorrection sometimes fails to take place in Safari.

What's up with this? Please fix it before landing the patch.
Comment 12 Jia Pu 2012-07-11 15:50:59 PDT
Manually landed after fixing the minor ChangeLog issue pointed by Ryosuke.
<http://trac.webkit.org/changeset/122380>