Bug 89811 - [Gtk] media/media-blocked-by-beforeload.html is flaky
Summary: [Gtk] media/media-blocked-by-beforeload.html is flaky
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2012-06-23 08:26 PDT by Zan Dobersek
Modified: 2014-05-16 12:02 PDT (History)
6 users (show)

See Also:


Attachments
Patch & layout test (3.82 KB, patch)
2014-05-15 00:19 PDT, Piotr Grad
no flags Details | Formatted Diff | Diff
Patch for layout test (3.11 KB, patch)
2014-05-16 02:51 PDT, Piotr Grad
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2012-06-23 08:26:15 PDT
http://test-results.appspot.com/dashboards/flakiness_dashboard.html#group=%40ToT%20-%20webkit.org&revision=121086&tests=media%2Fmedia-blocked-by-beforeload.html

It seems the loadedmetadata event is fired at different times, causing intermittent test failures:
--- /home/slave/webkitgtk/gtk-linux-64-release/build/layout-test-results/media/media-blocked-by-beforeload-expected.txt 
+++ /home/slave/webkitgtk/gtk-linux-64-release/build/layout-test-results/media/media-blocked-by-beforeload-actual.txt 
@@ -30,11 +30,11 @@
 
 EVENT('loadstart')
 
+EVENT('loadedmetadata')
+
+
 EVENT('error')
 EXPECTED (event.target.tagName == 'SOURCE') OK
 EXPECTED (video.error == 'null') OK
-
-EVENT('loadedmetadata')
-
 END OF TEST
Comment 1 Piotr Grad 2014-05-15 00:19:53 PDT
Created attachment 231493 [details]
Patch & layout test
Comment 2 Eric Carlson 2014-05-15 06:47:24 PDT
Comment on attachment 231493 [details]
Patch & layout test

This test is about the error events so I would prefer to leave as much logging in the results about those events as possible. The problem is the order of the 'error' and 'loadedmetadata' events is nondeterministic, so wouldn't it work to just not log the arrival of the 'loadedmetadata' event (remove the "logEvent(evt)" from loadedmetadata)?
Comment 3 Piotr Grad 2014-05-16 02:51:37 PDT
Created attachment 231564 [details]
Patch for layout test
Comment 4 Eric Carlson 2014-05-16 11:52:58 PDT
Comment on attachment 231564 [details]
Patch for layout test

Thank you for sticking with this!
Comment 5 WebKit Commit Bot 2014-05-16 12:02:26 PDT
Comment on attachment 231564 [details]
Patch for layout test

Clearing flags on attachment: 231564

Committed r168973: <http://trac.webkit.org/changeset/168973>
Comment 6 WebKit Commit Bot 2014-05-16 12:02:31 PDT
All reviewed patches have been landed.  Closing bug.