RESOLVED FIXED 89769
[chromium] Notify the document if a plugin accepts touch input events
https://bugs.webkit.org/show_bug.cgi?id=89769
Summary [chromium] Notify the document if a plugin accepts touch input events
Sadrul Habib Chowdhury
Reported 2012-06-22 10:38:25 PDT
[chromium] Notify the document if a plugin accepts touch input events
Attachments
Patch (4.41 KB, patch)
2012-06-22 10:43 PDT, Sadrul Habib Chowdhury
no flags
Patch (4.40 KB, patch)
2012-06-22 13:43 PDT, Sadrul Habib Chowdhury
no flags
Patch (4.41 KB, patch)
2012-06-22 15:13 PDT, Sadrul Habib Chowdhury
no flags
Sadrul Habib Chowdhury
Comment 1 2012-06-22 10:43:36 PDT
Sadrul Habib Chowdhury
Comment 2 2012-06-22 10:50:34 PDT
The corresponding chromium CL is http://codereview.chromium.org/10628020/
Adam Barth
Comment 3 2012-06-22 10:59:11 PDT
Comment on attachment 149057 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=149057&action=review > Source/WebKit/chromium/public/WebPluginContainer.h:111 > + // Notifies when the plugin starts/stops accepting touch events. > + virtual void setAcceptingTouchEvents(bool) = 0; setAcceptingTouchEvents -> setIsAcceptingTouchEvents or setAcceptsTouchEvents ? > Source/WebKit/chromium/src/WebPluginContainerImpl.cpp:601 > + if (m_acceptingTouchEvents && m_element->document()) > + m_element->document()->didRemoveTouchEventHandler(); How can m_element->document() be null? In the case where it becomes null, do we need to call didRemoveTouchEventHandler?
Adam Barth
Comment 4 2012-06-22 10:59:25 PDT
Is there a way to test this change?
Sadrul Habib Chowdhury
Comment 5 2012-06-22 13:43:18 PDT
Sadrul Habib Chowdhury
Comment 6 2012-06-22 13:44:48 PDT
Comment on attachment 149057 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=149057&action=review >> Source/WebKit/chromium/public/WebPluginContainer.h:111 >> + virtual void setAcceptingTouchEvents(bool) = 0; > > setAcceptingTouchEvents -> setIsAcceptingTouchEvents or setAcceptsTouchEvents ? Done. >> Source/WebKit/chromium/src/WebPluginContainerImpl.cpp:601 >> + m_element->document()->didRemoveTouchEventHandler(); > > How can m_element->document() be null? In the case where it becomes null, do we need to call didRemoveTouchEventHandler? I wasn't sure if it could be NULL so I added the check. I looked at the relevant code and did some testing, and it looks like it cannot be null. So I have removed the null-check here.
Sadrul Habib Chowdhury
Comment 7 2012-06-22 13:45:10 PDT
(In reply to comment #4) > Is there a way to test this change? I am working on writing a browser-test for this in the chrome side.
WebKit Review Bot
Comment 8 2012-06-22 13:48:55 PDT
Please wait for approval from abarth@webkit.org, dglazkov@chromium.org, fishd@chromium.org, jamesr@chromium.org or tkent@chromium.org before submitting, as this patch contains changes to the Chromium public API. See also https://trac.webkit.org/wiki/ChromiumWebKitAPI.
Adam Barth
Comment 9 2012-06-22 14:42:35 PDT
Comment on attachment 149093 [details] Patch Ok. A browser_test isn't ideal since we won't see it fail until after we roll WebKit into Chromium, but I can understand it's hard to make a LayoutTest for this case. Thanks for the patch.
Sadrul Habib Chowdhury
Comment 10 2012-06-22 14:45:15 PDT
Comment on attachment 149093 [details] Patch Indeed. Thanks for the quick review!
Adam Barth
Comment 11 2012-06-22 15:06:53 PDT
Comment on attachment 149093 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=149093&action=review > Source/WebKit/chromium/src/WebPluginContainerImpl.cpp:594 > + , m_acceptingTouchEvents(false) nit: This should be named m_isAcceptingTouchEvents also. The idea is that you should be able to read these boolean flags as a sentence "If this object isAcceptingTouchEvents ..."
Sadrul Habib Chowdhury
Comment 12 2012-06-22 15:13:54 PDT
Sadrul Habib Chowdhury
Comment 13 2012-06-22 15:14:44 PDT
Comment on attachment 149093 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=149093&action=review >> Source/WebKit/chromium/src/WebPluginContainerImpl.cpp:594 >> + , m_acceptingTouchEvents(false) > > nit: This should be named m_isAcceptingTouchEvents also. The idea is that you should be able to read these boolean flags as a sentence "If this object isAcceptingTouchEvents ..." Ah, good catch. Done. Thanks
WebKit Review Bot
Comment 14 2012-06-22 16:25:14 PDT
Comment on attachment 149117 [details] Patch Clearing flags on attachment: 149117 Committed r121070: <http://trac.webkit.org/changeset/121070>
WebKit Review Bot
Comment 15 2012-06-22 16:25:33 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.