Bug 89714 - ApplicationCache - verify that an open network whitelist doesn't break online vs fallback layering.
Summary: ApplicationCache - verify that an open network whitelist doesn't break online...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Michael Nordman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-21 17:11 PDT by Michael Nordman
Modified: 2012-06-22 15:31 PDT (History)
3 users (show)

See Also:


Attachments
layeringTest (1.51 KB, patch)
2012-06-21 17:18 PDT, Michael Nordman
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ec2-cr-linux-02 (869.23 KB, application/zip)
2012-06-21 21:20 PDT, WebKit Review Bot
no flags Details
layeringTest + DEPS (2.51 KB, patch)
2012-06-22 13:32 PDT, Michael Nordman
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Nordman 2012-06-21 17:11:31 PDT
An explicit online network namespace should trump a fallback namespace, the fallback should not be used.  Chrome had a bug where if a '*' was in the NETWORK section, explicit entries got ignored, and that expected behavior was botched. See http://code.google.com/p/chromium/issues/detail?id=133816 for more details about the chrome bug and code change this LayoutTest aims to verify.
Comment 1 Michael Nordman 2012-06-21 17:18:47 PDT
Created attachment 148917 [details]
layeringTest
Comment 2 Michael Nordman 2012-06-21 19:14:11 PDT
@tony, here's that layout test change i mentioned
Comment 3 Michael Nordman 2012-06-21 20:39:48 PDT
need a deps to 143410 for the modified test to pass in chrome, right now its at 142842... http://trac.webkit.org/browser/trunk/Source/WebKit/chromium/DEPS
Comment 4 WebKit Review Bot 2012-06-21 21:20:25 PDT
Comment on attachment 148917 [details]
layeringTest

Attachment 148917 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/13029341

New failing tests:
http/tests/appcache/online-fallback-layering.html
Comment 5 WebKit Review Bot 2012-06-21 21:20:28 PDT
Created attachment 148957 [details]
Archive of layout-test-results from ec2-cr-linux-02

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: ec2-cr-linux-02  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.35-28-virtual-x86_64-with-Ubuntu-10.10-maverick
Comment 6 Tony Chang 2012-06-22 10:30:55 PDT
Comment on attachment 148917 [details]
layeringTest

Feel free to add the chromium DEPS roll to this change.
Comment 7 Michael Nordman 2012-06-22 13:32:29 PDT
Created attachment 149092 [details]
layeringTest + DEPS
Comment 8 Michael Nordman 2012-06-22 13:43:12 PDT
thnx tony, turns out there's a DEPS roll making its way thru the cq now (bug 86275), so i'll cq+ my original patch instead of the latest one after that lands
Comment 9 Tony Chang 2012-06-22 14:14:35 PDT
SGTM
Comment 10 WebKit Review Bot 2012-06-22 15:30:50 PDT
Comment on attachment 148917 [details]
layeringTest

Clearing flags on attachment: 148917

Committed r121062: <http://trac.webkit.org/changeset/121062>
Comment 11 WebKit Review Bot 2012-06-22 15:31:15 PDT
All reviewed patches have been landed.  Closing bug.