Bug 89555 - Web Inspector: Move requestId allocation from FileSystem frontend to backend
Summary: Web Inspector: Move requestId allocation from FileSystem frontend to backend
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Taiju Tsuiki
URL:
Keywords:
Depends on:
Blocks: 68203 73301 87856
  Show dependency treegraph
 
Reported: 2012-06-20 02:31 PDT by Taiju Tsuiki
Modified: 2012-06-21 00:24 PDT (History)
11 users (show)

See Also:


Attachments
Patch (23.87 KB, patch)
2012-06-20 02:37 PDT, Taiju Tsuiki
no flags Details | Formatted Diff | Diff
Patch (23.84 KB, patch)
2012-06-20 19:06 PDT, Taiju Tsuiki
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Taiju Tsuiki 2012-06-20 02:31:46 PDT
Per https://bugs.webkit.org/show_bug.cgi?id=87856#c6, we should allocate requestId in backend-side,
 and should rename getFileSystemRoot and readDirectory to requestFileSystemRoot and requestDirectoryContent.
Comment 1 Taiju Tsuiki 2012-06-20 02:37:04 PDT
Created attachment 148527 [details]
Patch
Comment 2 Vsevolod Vlasov 2012-06-20 14:07:30 PDT
Comment on attachment 148527 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=148527&action=review

Please fix a couple of nits before landing.

> Source/WebCore/ChangeLog:10
> +

Please remove extra blank line.

> Source/WebCore/inspector/Inspector.json:1441
> +                    { "name": "requestId", "$ref": "FileSystem.RequestId", "description": "Request identifier. Corresponding fileSystemRootReceived event should have same requestId with this." }

"$ref": "RequestId" is enough since you are inside FileSystem domain.

> Source/WebCore/inspector/Inspector.json:1453
> +                "description": "Returns content of the directory as didReadDirectory event."

didReadDirectory ->directoryContentReceived

> Source/WebCore/inspector/InspectorFileSystemAgent.cpp:413
> +    ASSERT(requestId);

This is up to the protocol implementation to provide correct output parameter pointer, you should not check it here.

> Source/WebCore/inspector/InspectorFileSystemAgent.cpp:427
> +    ASSERT(requestId);

Ditto.
Comment 3 Taiju Tsuiki 2012-06-20 19:06:08 PDT
Created attachment 148709 [details]
Patch
Comment 4 Taiju Tsuiki 2012-06-20 19:09:08 PDT
Comment on attachment 148527 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=148527&action=review

Thanks, I updated the patch.

>> Source/WebCore/ChangeLog:10
>> +
> 
> Please remove extra blank line.

Done

>> Source/WebCore/inspector/Inspector.json:1441
>> +                    { "name": "requestId", "$ref": "FileSystem.RequestId", "description": "Request identifier. Corresponding fileSystemRootReceived event should have same requestId with this." }
> 
> "$ref": "RequestId" is enough since you are inside FileSystem domain.

Done

>> Source/WebCore/inspector/Inspector.json:1453
>> +                "description": "Returns content of the directory as didReadDirectory event."
> 
> didReadDirectory ->directoryContentReceived

Done

>> Source/WebCore/inspector/InspectorFileSystemAgent.cpp:413
>> +    ASSERT(requestId);
> 
> This is up to the protocol implementation to provide correct output parameter pointer, you should not check it here.

Removed

>> Source/WebCore/inspector/InspectorFileSystemAgent.cpp:427
>> +    ASSERT(requestId);
> 
> Ditto.

Removed
Comment 5 WebKit Review Bot 2012-06-21 00:24:05 PDT
Comment on attachment 148709 [details]
Patch

Clearing flags on attachment: 148709

Committed r120906: <http://trac.webkit.org/changeset/120906>
Comment 6 WebKit Review Bot 2012-06-21 00:24:09 PDT
All reviewed patches have been landed.  Closing bug.